PDA

View Full Version : External USB2.0 Drive won't eject from G5...




agentphish
Aug 12, 2007, 06:19 PM
Anyone have suggestions? I have a single 1.8ghz g5, 1gb ram, 10.4.10. I have a maxtor OneTouch III USB 2.0 200gb drive attached to it.

I can not seem to eject/unmount this drive. Every time i hook it up I just have to end up pulling the USB plug or turning the drive off suddenly to get it to "eject" but then i get the improper device removal error/warning message.

I have tried dragging to trash, I have tried apple E (which is what I usually do to any device) and I have tried going into disk utility and ejecting/unmounting from there as well. no dice.

Suggestions please? Thanks!



agentphish
Aug 12, 2007, 06:51 PM
Nevermind, after some more digging i finally ran across a post that told me exactly the problem. Somehow there was trashes that were not empty, yet I didn't have the option to empty them so I found an applescript on MacOSXHxxts that empty's the trash on whatever volume you drag to it after you have saved it as an application.

Thank goodness. problem solved!