PDA

View Full Version : New Apple Keyboard (volume control) issues.




Jeremy Gray
Aug 13, 2007, 02:48 PM
Hi, I'm using the new Apple Keyboard (wired) with my Mac Pro, and I can't seem to figure out how to use F9-F12 keys for volume control and not for Dashboard and stuff like that. I know this should be an obvious fix, but I'm drawing a blank on how to fix this.



kbmb
Aug 13, 2007, 03:01 PM
Hi, I'm using the new Apple Keyboard (wired) with my Mac Pro, and I can't seem to figure out how to use F9-F12 keys for volume control and not for Dashboard and stuff like that. I know this should be an obvious fix, but I'm drawing a blank on how to fix this.

Don't have the keyboard, so I don't know for sure, but wasn't there a software update after the keyboard was released? Maybe run software update to see if you get new keyboard software that recognizes the new layout?

-Kevin

A Pittarelli
Aug 13, 2007, 03:02 PM
ive been thinking asbout getting one for my macbook for my desk

devman
Aug 15, 2007, 01:23 AM
Attach the keyboard, then run software update to download the keyboard update. Reboot.

This was the trick on my laptop (I assume the same pref is there for a desktop).

System Preferences->Keyboard&Mouse->Keyboard

Then untick Use all F1, F2, etc. keys as standard function keys.

I don't know if that's your problem but it is what got it going it for me.

mmccaskill
Aug 15, 2007, 06:43 AM
I bought the new wired keyboard for my MacBook, installed keyboard update through Software Update & manually downloaded it. The only keys that I can get working are the volume keys. None of the other keys do anything. I've tried playing with System Prefs->Keyboard&Mouse but to no avail.

Seems interesting that more and more peopl are having this problem. I'm seeing crop up in discussions.apple.com

zami
Aug 15, 2007, 08:26 AM
I bought the new wired keyboard for my MacBook, installed keyboard update through Software Update & manually downloaded it. The only keys that I can get working are the volume keys. None of the other keys do anything. I've tried playing with System Prefs->Keyboard&Mouse but to no avail.

Seems interesting that more and more peopl are having this problem. I'm seeing crop up in discussions.apple.com

Worst of all the Option/Alt key cannot be used at boot to select the drive or partition desired anymore. That is criminal Apple. Why has this function been removed?

rhildinger
Aug 15, 2007, 03:04 PM
Worst of all the Option/Alt key cannot be used at boot to select the drive or partition desired anymore. That is criminal Apple. Why has this function been removed?

Just in case you don't see my reply to your other thread regarding the new wired keyboard...

I bought the new wired keyboard for my Mac Pro and the option key works perfectly for selecting the startup drive/partition, so apparently this function hasn't been removed.

Streetwise
Sep 6, 2007, 09:31 PM
My issue is with volume control as well. On my MAC PRO, using a wired keyboard. I had it set up with external speakers and was able to control volume with keyboard. Now all of the sudden that doesn't work any more. All I can control is the internal speakers. What's up with that? I didn't install any update or anything else...

Thoughts?

mlcramton
Jan 5, 2008, 07:46 PM
The solution lies here:
http://www.apple.com/support/downloads/keyboardsoftwareupdate12.html

Download. Restart. Done.

Streetwise
Jan 7, 2008, 07:52 AM
Thanks for the link! That seems to have fixed the problem (at least after a reboot). We'll see if it permanently fixed it...

BTW - Your post might have cost me $49 :o ; I didn't know that Apple has an aluminum keyboard until I clicked on your link. Nice!

Streetwise
Jan 15, 2008, 12:06 PM
The solution lies here:
http://www.apple.com/support/downloads/keyboardsoftwareupdate12.html

Download. Restart. Done.

Well just I feared... I had to reboot for some reason and now the issue is back. I re-installed the keyboard update, restarted, and it's still a problem... So it's definitely something that's beyond the keyboard updater. I wonder if Leopard fixes it?

Thanks.