PDA

View Full Version : AppleTV remote doesn't work when streaming Movies




scheringj
Aug 23, 2007, 11:38 AM
I have recently started streaming movies to my appleTV, but when I do this the appleTV stops or barely ever registers the buttons I've pressed. It's quite frustrating as the remote works perfectly fine when I play a movie that's been synced. I've also been able play YouTube video's and trailer clips without problems. I have an 2.8Ghz iMac and an Airport Extreme with 802.11n. It seems that the remote will work if it's only a foot or 2 away from the AppleTV, but won't if it's any more than that. I get no stuttering when streaming it's just that the remote stops working for the normal distance I use it when it's synced. The remote will also work when navigating the menu just before I play a streaming movie. Any suggestions would be great.

thanks.



vandlism
Aug 23, 2007, 11:47 AM
Well unless you are dousing the things with IR beam when watching the movie, I don't think there should be interference with the signal. Additionally, since it works at all times except when streaming, I would assume the remote's batteries are fine and otherwise functions perfectly. My guess is that its getting the signal but not controlling the movie fast enough...which points to network speed/connection. You say you have an iMac and an Airport Extreme N. Is the AppleTV or the iMac connected to the Airport with an ethernet cable? The iMac should be running on N, as I assume it's the new one. There could also be interference on the 2.8ghz spectrum, and seeing as how all 3 of your networked components support wireless N, would it be possible for you to switch your Aiport to wireless N exclusively on 5.4ghz? or do you need to keep compatibility with a/b/g? I have had my AppleTV stream from an external connected to my MacBook with G, and it worked just fine. So I'm thinking there may be some sort of interference.

Or...I could be completely wrong.

scheringj
Aug 23, 2007, 12:03 PM
Thanks for the reply. The airport is actually running on the 5Ghz spectrum so that's not helping. It's as if the appleTV streaming content interferes with the apple remote. Though I don't have problems with YouTube or movie trailers. It's also strange that the remote works when it's 2 feet away but not more when streaming. It works perfectly fine up until I press play on the movie and then it doesn't register the buttons I've pressed unless I stand right in front of it.

Any other ideas?

vandlism
Aug 23, 2007, 01:20 PM
Well as far as I know, the AppleTV fetches YouTube videos and trailers on its own from the internet. Streaming movies requires it to connect to the iMac. That's the only reason I truly thought it had something to do with the network connection. As far as interference between the streaming video and the remote: the remote works off of infrared lights/sensors and the streaming is over radio waves so there is nothing to interfere there.