PDA

View Full Version : iBook - boots straight to open firmware...




Nick012
Aug 25, 2007, 02:50 PM
DEFAULT CATCH!, code=300 at SRR0: 5555554 SRR1: 40003030

typing 'mac-boot' gets me to a white screen with black lines all down it. It just hangs there.

I tried zapping the PRAM but it didn't help. The hard drive has been making those *click click* 'I'm about to die' sounds for a while. I'm assuming its the hard disk . I have another iBook with a failed logic board I can take the HD out of but in case its not I don't want to take it apart just yet.
Opinions?



ITASOR
Aug 25, 2007, 02:55 PM
Broken HD shouldn't really make it boot into OF unless it's something more serious.

Type "reset-all" at the prompt (it will restart) and see if that does anything.

mkrishnan
Aug 25, 2007, 02:55 PM
Hmmm, a failed hard drive should not result in a boot to open firmware. It should result in you getting a gray screen with a flashing folder / question mark in the center.

When you reset the PRAM, did you do it with Cmd-Opt-P-R, or did you do the following commands in OF:

set-defaults
reset-nvram
reset-all

I wonder if for some reason OF doesn't have a defined boot device?

Also can you boot an install CD/DVD?

Nick012
Aug 25, 2007, 03:02 PM
I tried the reset-all and the others but it didn't work. I hav no idea. Any clue to what it might be?
I'll root through some boxes for the restore disk.

mkrishnan
Aug 25, 2007, 03:13 PM
For the three commands that I gave, you really should do them in order, as listed (all three). As far as I know, that's fairly exhaustive. But I'm not sure it's the issue anyway.

This blog post (http://paulschreiber.com/blog/2005/04/17/open-firmwares-default-catch/) describes something fairly similar that was fixed by simply booting from the install disc and then selecting the HD as the boot device.

Nick012
Aug 25, 2007, 03:23 PM
I did do them in order and as listed (should probably have been clearer about that). It doesn't want to boot from the restore disk, still boots to OF.
One would assume that this iBook is somewhat dead...

mkrishnan
Aug 25, 2007, 03:49 PM
Mmm...that doesn't sound good at all... you tried some different ways to try to make the restore disc boot, right (holding c, holding option, etc)?

The thing that strikes me as odd is that even if the ATA controller went down (I got to experience this in essence first hand, with my iMac, although the iMac has a SATA controller for the HD and a separate ATA controller for the DVD-RW -- and only my SATA died), you should get a graphical boot response and not open firmware.

Well, if I can remember why your issue sounds vaguely familiar and re-google whatever I read that might've applied, I will let you know. In the meantime, good luck! :(