PDA

View Full Version : Help: Kernel panic after replacing hard drive in Powerbook 17"




pimes
Aug 27, 2007, 12:41 PM
I need help with a kernel panic that won't even let me start up. Here's a detailed account of what happened:

The hard drive in my Powerbook 17" recently failed. Since it is out of warranty anyway, I decided to try to replace it myself. I found a good tutorial with photos online and was careful to rehook everything appropriately. After the replacement, I immediately installed OS 10.2 from my Apple Software Restore CD. It seemed to successfully install on the new HD.

After installing OS X, I restarted. I got the Apple logo on the grey screen but as soon as the "gear" started spinning, I got a kernel panic. I tried resetting the PRAM and the PMU but still got the panic message so I fired up Apple Hardware Test CD. Without even running the test, it gave me the message that errors were detected with my RAM upon startup. In the Hardware Profile tab, under Memory Overview, it showed:
768/1024
SODIMM0/J20STANDARD512/512
SODIMM1/J23REVERSED256/516

The last line "SODIMM1..." was red. It appeared that one of the sticks of RAM was damaged. However, when I swapped the sticks, I still got the kernel panic, but the Hardware Profile no longer listed either of the sticks in red and the full 1024/1024 MB was shown.

Does anyone have any idea why I am still getting a panic message? Could I have damaged the RAM itself or the RAM slot? (I was very careful when pulling it out.) Any help would be much appreciated. This has been a great computer for about 6 years and I hope to get another few out of it!

Peter



mad jew
Aug 27, 2007, 09:49 PM
There were some problems with the RAM slots on these machines, from memory. Have you tried completely removing RAM from the dodgy slot and running with one chip?

pimes
Aug 28, 2007, 08:27 AM
I experimented with this a little last night. By switching the RAM sticks, the memory problem seems to be resolved. I was still getting the kernel panic though so I put the original hard drive (which is on the verge of crashing) back in the machine and everything booted up just fine. It seems like the problem may actually be with the new hard drive. I don't need to do anything to the drive other than pop it in the machine, right?

mad jew
Aug 30, 2007, 08:44 PM
I'm confused. Is the problem resolved are are you still getting the panics? Run with one stick in the top slot for a while and see if that helps. I still think this is a RAM-related problem but I'm not sure if it's a chip or a slot.

rodobrodo
Feb 13, 2008, 07:04 PM
Good Day

I left my laptop off for 3 months with no baterrie, duo a trip to EU, after trying to turn it on , I could not get pass by the Kernel display,
I did backup my system through firewire as slave HD, I can start the computer holding down shift at startup, but then a few functions wont work, it is just the safe boot.

I re-install my MAC OSX 10.4 then the up date to 10.4.11 but still no lock.

I also try to connect it to the internet via ethernet cable but I guess it is disable.

I really don't know what else to do,