PDA

View Full Version : Powerbook G4 Unusable after 2 Years-Extremely Disappointed




Jay42
Sep 3, 2007, 12:24 PM
My G4 Powerbook (15-inch, 1.5 ghz) is now practically unusable after only 2 years. It will go to sleep randomly when I am in the middle of doing something and will go back to sleep almost immediately after I wake it up again. It will only stay on for about 5 seconds at a time before falling asleep again. The laptop itself feels cool so I dont think it is overheating. Nothing seems to help it although occasionally it will stay on for a few of minutes after leaving it alone for a couple of hours.

I think this problem has to do with the heat sensor on the logic board. It seems like the sensor is bad and will tell the machine to go to sleep to prevent it from overheating even if it isn't. Does anyone else have this issue? It will now be very hard to diagnose because the laptop does not stay on for more than a few seconds at a time, so it is practically dead. Yes I should have bought apple care, but I really didn't expect an issue as serious as this to happen so fast. I am pretty disappointed because I am now in a tough situation with classes about to start and no Apple store near by. With all of the expenses and responsibilities I have right now at school, this is really the last thing I need.

Is there anyone who could offer any advice besides just biting the bullet and sending it in for repair?



iSaint
Sep 3, 2007, 12:40 PM
All I can tell you is that I had a good experience with Apple repair with a nearly three year old iBook that died on me. If I had bought Applecare, it would have saved me $100. In other words, I paid $299 for the repair and practically have a new iBook!

Apple has a fast turnaround, usually. Take it to a Genius and see what they say.

AdeFowler
Sep 3, 2007, 12:47 PM
I have exactly the same model as you, but over 3 years old (typing on it now).

Have you tried all the normal trouble shooting, i.e.


create a new user and use that account for a while?
reset PRAM;
run Hardware test;
re-install OSX.

Makosuke
Sep 3, 2007, 03:56 PM
I assume you've already checked this, but I've seen what you're describing happen because of a bad battery.

If it's not plugged in, that's exactly how it will behave if the battery is drained, and if the battery "fails" (which does happen sometimes), it'll do that even if it's apparently got capacity left. I had one of that bad Sony batch, and it ended up doing something very similar to me until I had it replaced under warranty.

The easiest way to test would be to remove the battery, plug it in, and see if it does that. If so, then definitely not power related. If not, the battery is messed up (and if it won't start at all, the AC adapter is bad and not properly charging the battery).

beige matchbox
Sep 3, 2007, 04:21 PM
I had that problem too.

It ended up being the temp sensor near the trackpad had gone south, i removed the pins on the chip that send a warning when it think it's overheating. It's not gone to sleep randomly since, however the sensor is still giving out wild values...


AFIK, apple made a revision to the top case with a different sensor, and/or layout


However, just incase you get the urge to go happy hacker on it, i'd do what Southernboy suggested first, just in case ;)


****edit****

Added a pic of the doodad in question, the chip above the connector. Their located on the flexi that connects the top case to the logic board if i remember correctly

Jay42
Sep 4, 2007, 11:53 AM
Appreciate the advice, although I don't know if I really want to take this thing apart right now.

Is it possible that a bad battery could cause it to go to sleep even when plugged in (and with the battery in)?

Makosuke
Sep 4, 2007, 06:39 PM
Is it possible that a bad battery could cause it to go to sleep even when plugged in (and with the battery in)?Probably not, but it's theoretically possible if either the adapter or the charging system isn't working.

That's why I suggested trying it plugged in WITHOUT the battery--if it works fine, then it's definitely a power-related problem, probably related to a misbehaving battery.

If, plugged in and without the battery in at all, it works for a while then abruptly powers off (as opposed to abruptly going to sleep), you've got a bad charger or power circuitry, and without the battery there it's just dying.

If, plugged in and without the battery in it does exactly the same thing, then it's definitely heat related.