PDA

View Full Version : My G4 Quicksilver went mad!


groovebuster
Aug 13, 2003, 07:00 PM
I am so angry, you can't imagine it! Today I figured out how to easily cause a complete data loss under Mac OS X (10.2.6). Just keep the mouse button pressed right after you woke the computer from deep sleep. It will shut down immdiately again. Then try to start it again and notice that the Finder will freeze bit by bit, because the file system is corrupted. Next time you try to boot you get nothing but the Apple logo in the beginning, that's it! Freeze!

Man, I'm pissed! I am in the middle of a very important production and now my system is totally screwed and everything(!) is lost! It will take me days to recover everything...

Screw the UNIX under the hood of Mac OS X! With OS 9 (or earlier) I never had a total data loss in all the years I used a Mac!

:mad:

groovebuster

simX
Aug 13, 2003, 07:07 PM
Have you tried the standard troubleshooting methods?

1) Starting from the OS X CD and running Disk Utility, and/or booting into single-user mode and using "/sbin/fsck -y" to repair your drive.

2) Using DiskWarrior or TechTool or similar program to repair your drive.

3) Opening your G4, taking out the hard drive, and installing it into a different tower as a secondary drive so you can easily fix it from there?

4) There are other minor ones (zapping PRAM, etc.), but since you mentioned file-system corruption, they probably won't help that much.

I understand your frustration, and it's easy to get mad, but I wouldn't go blaming it on Mac OS X -- I've seen a fair share of Mac OS 9 systems do the same thing.

Hopefully you can get your problem solved by using one of the above methods.

King Cobra
Aug 13, 2003, 07:09 PM
Nice ranting.

FIRST, try resetting your firmware and zapping your PRAM. This is something you should do BEFORE you assume you have lost everything.

Firmware:
Apple -- Option -- O -- F (upon boot)
type in:
reset-all

PRAM:
Upon boot, hold on for one straight minute:
Apple -- Option -- P -- R

Second, run a file system check.
Apple -- S (upon boot)

When all processes have finished, type in:
fsck -y

Type this in again after all processes have finished if you have any one correction that has to be made to the system.

When you have a plus, type in:
mount -uw /
reboot


Edit: Just read above post.

Try these methods first, then work with the utilities previously mentioned. Start light, then work to more and more advanced methods.

macphoria
Aug 14, 2003, 11:26 PM
I hate to ask these questions in time of your troubles, but I still have to ask.

Why were you holding down your mouse after you woke up your computer? And how do you know your data is lost if you can't get past Apple logo screen?

I think simX and King Cobra gave pretty thorough means of getting your Mac back. Once you manage to boot your computer properly, you should be able to get your data back. I think.