PDA

View Full Version : Powerbook G4 17" fails to start




joshboese
Sep 17, 2007, 10:17 PM
I was recently reinstalling the keyboard within my 17" Albook. The computer booted fine and worked for maybe less than an hour, and then on a reboot shut down abruptly before OS X was finished loading. I restarted and was able to log in for several minutes. Now, upon opening the system, I noticed while replacing the RAM door I missed the slot it should fit into and it was put into place below this (which apparently is right over the CPU)...and when I pulled this part out there was some thermal paste along the edge. Looking into this area with a flashlight, the thermal paste seems sort of messy and some is in front of the chip rather than directly on it.

How likely is it that lack/messiness of paste is what is causing this? The battery fully charges within the system and the AC light is on. When I attempt to boot the machine, you can hear the HD, fans, and Superdrive spin for a second but you never see anything on screen.

Another thing that maybe the problem - when reinstalling the keyboard i forgot to replace the adhesive seperating the keyboard mount area and screws from the logic board - the first time the system shut down, I brushed my hand across the newly installed keyboard and the system shut right down. I'm not sure if this caused the overheating CPU to shut down, or if this caused the keyboard to contact with the logic board and I shorted it out and need a new one. I've since replaced this adhesive insulation plastic and the system still won't boot.

Any help would be appreciated. Please leave suggestions. I don't want to lose my mac :(