PDA

View Full Version : iPod touch randomly losing connection to wifi?




TheSpaz
Sep 22, 2007, 08:32 PM
A lot of the time, I will be browsing the web or checking out YouTube videos when all of a sudden wifi will disconnect and I'll have to stop what I'm doing and find the wifi settings and reconnect. What the heck.

Edit: I am not moving while this happens.



Schnebar
Sep 22, 2007, 09:10 PM
same thing happens to me.

Usually when the wifi is not that strong.

I still dont know what is better to select. Ask to connect on or off.

ox4dboy
Dec 15, 2008, 12:01 PM
I have the same problem. iPod Touch G2, Belkin 54g Router. I've read a few posts about setting NAT type to Open - but my router settings do not list "open" as an option. Here is what I see when I go to my Router's settings:

NAT Enabling:
ADVANCED FEATURE! Allows you to turn the Network Address Translation feature off. In almost every case you would NOT want to turn this feature off. More Info
- NAT Enable / Disable > (•) Enable ( ) Disable

Is this the same as "Open"

Any ideas? Have you solved this problem? How?

bassproguy07
Dec 15, 2008, 12:09 PM
My iPhone has done this since day 1, I dont think the antenna in the iPhones and touch's is very strong because mine always cuts out when I am on the web or on youtube, and I have a fancy wireless N router that always has signal.

ox4dboy
Dec 15, 2008, 01:43 PM
Seems to happen even if my iPod Touch is sitting right next to the router.

ThunderBull4
Dec 15, 2008, 06:09 PM
Might have something to do with the 2.2 firmware on some devices. I would try a simple restore, and make sure to back up your stuff. Mine never cuts out... i have 1st gen 2.2 jailbroken, with linksys wireless router.

skilledone
Dec 26, 2008, 08:19 AM
A lot of the time, I will be browsing the web or checking out YouTube videos when all of a sudden wifi will disconnect and I'll have to stop what I'm doing and find the wifi settings and reconnect. What the heck.

Edit: I am not moving while this happens.

Bleh, I'm getting wifi issues also and this is at both work and home. The wifi signal is strong, but after streaming radio for say 20+ minutes or so the wifi connection will just drop randomly. I'll then have to go to wifi settings and select the network a couple of times for it to reacquire the signal/connection. Very annoying. Oh and I have 1st GEN IPOD Touch

Hello-
Jan 28, 2009, 05:12 PM
I have the exact same problem with a 1st gen ipod touch jailbroken with quickpwn on firmware 2.2. Whenever I run Rooms v0.7 for 20-30 minutes with the screen on the wifi shuts down and I can't get it back unless I quit rooms and activate another app which uses the internet. Weird thing is I can run the shoutcast radio app for hours streaming music without disconnecting. Also, if the iPod is charging off the wall charger Rooms will stay connected. I've tested this and it's stayed online and idle for 24hrs with the screen off. Before firmware 2.x I ran colloq for irc in firmware 1.1.4 and it was able to stay connected for hours at a time. That was a long time ago so things could have changed both hardware and software on my ipod.

This also happens sometimes when I'm browsing through web pages in Safari and while playing Scrabble over wifi with an iphone. Wiped my ipod completely on firmware 2.2 and tried reverting to 2.1 and the wifi still cuts out in both cases.

Does anyone have a solution for this short of bringing my out of warranty ipod back to the apple store to be repaired or replaced for $$$? :apple::apple::apple:

SkyBell
Jan 28, 2009, 05:18 PM
I do think it is the 2.2 firmware. My iPod touch worked just fine with 2.1. Not anymore... and restoring to 2.1 is such a pain in the butt, it's just not worth it.

pilotrtc
Jan 29, 2009, 06:21 AM
I have this experience also and posted a similar thread. The answer I received is that it's a known (at least known to us) bug that has to do with the iPod itself. It was suggested that it's a firmware issue. There were hopes the next update would fix it (this recent one, 2.2.1) but, alas, I suffered from the problem practically moments after I updated. :(

cmichaelb
Jan 29, 2009, 11:55 AM
double post

cmichaelb
Jan 29, 2009, 11:57 AM
Bleh, I'm getting wifi issues also and this is at both work and home. The wifi signal is strong, but after streaming radio for say 20+ minutes or so the wifi connection will just drop randomly. I'll then have to go to wifi settings and select the network a couple of times for it to reacquire the signal/connection. Very annoying. Oh and I have 1st GEN IPOD Touch

I do think it is the 2.2 firmware. My iPod touch worked just fine with 2.1. Not anymore... and restoring to 2.1 is such a pain in the butt, it's just not worth it.

My 1G( 1.3 firmware ) has had this problem since day one. Same for my 2G( 2.0 firmware ). The problem has been around for me in every firmware.

2.2.1 seems to be a bit better about it so far, but that may just be coincidence.



1.4 firmware and 2.1 made it so I couldn't get on public wifi networks in addition to the wifi signal drops.

TheSpaz
Jan 29, 2009, 12:19 PM
My 1G( 1.3 firmware ) has had this problem since day one. Same for my 2G( 2.0 firmware ). The problem has been around for me in every firmware.

2.2.1 seems to be a bit better about it so far, but that may just be coincidence.



1.4 firmware and 2.1 made it so I couldn't get on public wifi networks in addition to the wifi signal drops.

FYI: There was no firmware 1.3 or 1.4.

cmichaelb
Jan 29, 2009, 12:33 PM
FYI: There was no firmware 1.3 or 1.4.

Really? then what was on my 1G Touch?

TheSpaz
Jan 29, 2009, 12:57 PM
Really? then what was on my 1G Touch?

1.1
1.1.1
1.1.2
1.1.3
1.1.4
1.1.5
2.0
2.0.1
2.0.2
2.1
2.2
2.2.1

If you're still confused... look here: http://en.wikipedia.org/wiki/IPhone_OS_version_history

As you can see, there was never a 1.3 or 1.4