PDA

View Full Version : Powerbook G4 dies without mains plugged in?




Sharky II
Sep 27, 2007, 07:57 AM
Hi there

I have a 47 month old Powerbook G4 1.25ghz, 15inch. It has a newish battery (3-4 months), and it seemed to be working fine.

Last night i left the laptop on overnight (not plugged into the mains) as i fell asleep, and obviously the battery died, as it should.

When i woke up, the computer was totally 'off' (not asleep), and booted okay once plugged into the mains. As the computer was plugged in, the battery was charging as normal.

Long story short, now the computer won't work without being plugged into the mains, even though the battery is charged and Coconut battery says it is 100% charged and 88% of original capacity. Sometimes even when i plug the mains in to boot it, the startup noise is a little weird. But it seems to be ok now.

Anyone experienced this before? Any solutions?

I'm going to try to reset PMU, and also try one of the old batteries (that don't last very long, but long enough to let me know if it's the battery or the psu) i have at home, when i get back after work. Just wondering if this is a common problem.

Cheers,

Edd



kiwi-in-uk
Sep 27, 2007, 08:28 AM
I can't help you Sharky II, but I'm very interested in what you find out.



I have a 42 mth old PB 1.33 17". The original battery is around 50% capacity and lasts a bit over an hour (less than what I need) so I'll be looking to get a new battery to make the old beast last a while longer. If anyone has had similar problems with this model I'd like to know ahead of time.

Cheers

Sharky II
Sep 27, 2007, 08:29 AM
power management reset - no joy :(

iSee
Sep 27, 2007, 08:38 AM
One day my MBP started having the same symptoms as you describe (except the part about the funny startup sound). Replacing the battery solved the problem. (The battery had been about 6 months old.)

I wonder if there is a way to reset the battery? (the Li batteries are 'smart', I think--they've got some chips and store some state info. It seems like there should be some way to reset that.)

Maybe someone knows how to reset these kinds of batteries... like press and hold the button for 20 sec or something...

Maybe look in to the warranty on the new battery.

bslax28
Oct 9, 2007, 11:31 PM
I just wanted to add that I have a powerbook 12" g4 1.5 ghz... i have had this same problem before and they replaced the battery. this was a year ago. it just started doing it again. ill be using hte battery, the meter will read 56% or so, tehn itll just shut off. When I plug it in, it starts from 0. I'm not sure what to do, since I've already once had the battery replaced and no longer have apple care. does anyone have any suggestions?

bslax28
Oct 11, 2007, 08:05 AM
just to add to this - it's only getting worse. now it turns itself off at 76%, and soemtimes when i plug it back in it says its at 0 and sometimes it says its still at 76. and again, i got a new battery just last year!