PDA

View Full Version : Can't get compilations to show as ONE album or in sequential order.




reubs
Oct 4, 2007, 01:09 PM
I downloaded the REM tribute from Stereogum, and I'm having some problems getting all of the songs to show up as ONE album and to play in sequential order. By this, I mean that 11 and 12 are reversed and they each show up as individual albums. Therefore, I have ten songs on one album, and two songs on two albums each.

Also, I've added bonus songs to an album that had some exclusive tracks, and I can't get them to attach to the END of the album. Despite being labeled as tracks 11, 12, etc. they keep showing up at the beginning of an album on my iPod.

Any help here? Does that make sense?



adamtce
Oct 4, 2007, 01:25 PM
this mite help.
open iTunes and type the name of the artist so that it is only artist or CD showing up. then click Control + A, then use the get info option.
when that opens, make sure the all the songs are labeled the write name and album. also another thing you could check is if the tracks 11 & 12 are labeled with 'disc 1 of 1' of something. that maybe causing them show up separately

hope this helps

plinden
Oct 4, 2007, 01:31 PM
Select all the songs you want to be in the same album, "Get Info", select the info tab, and select the "compilation" box in the bottom left.

You can also set the song order per song using Get Info.

Multimedia
Oct 4, 2007, 01:40 PM
1. Best way including the above tips is to start by putting all the tracks you want to be one album in a new playlist.
2. Then make sure all the track numbers are what you want them to be.
3. Then make sure the Disc numbers are right. Select all of disc 1 then Command + i then make the disc fields 1 of 2 and same procedure for disc 2 of 2. If it's only one CD then select all, get info and make the disc numbers fields BLANK. If it's two CDs then make sure each track is in the correct disc number of the total number of discs.
4. Then Select ALL and make sure the album name is ONE NAME with the compilation box checked at the bottom as well as any other common info for the whole album like the release year.
5. Once all the above are done, you should be able to highlight the disc column for all of disc 1 to appear before any of disc 2. And the track numbers should be in order as well at that point.

andrewcirulis
Oct 31, 2007, 06:03 PM
If you want just one sleeve for your compilation albums to appear in CoverFlow, and still be able to identify the different artists on your compilation albums, try the following...

First, change every artist's name on the album to "Various Artists" (this tricks the iPod into thinking that they're all the same artist, and it therefore allocates just one sleeve to appear in CoverFlow).

Next, rename the songtitles so that they incorporate the artist's name at the beginning, eg, instead of the song title being just "Roll With It", rename it to "Oasis: Roll With It". This way, you should just get one sleeve appearing in CoverFlow (with the correct album name, and "Various Artists" beneath it) plus be able to identify the individual artists as well. It's not perfect, but it sort of works.

As far as I can tell, selecting the "compilation" option in iTunes only makes the album appear in the compilation section of your iPod.

MrSmith
Oct 31, 2007, 07:39 PM
What do 'Remember Position' and 'Skip When Shuffling' do exactly?