PDA

View Full Version : Major fault - playlist on Touch different to iTunes




joefinan
Oct 5, 2007, 07:02 AM
Just got my Touch (at last).

I have an iTunes playlist called 'Chart' - 200 most-played tracks. However, on that playlist on my Touch it has 200 seemingly random tracks which don't even appear in the original 'Chart' playlist.

What the hell is that about? Anyone else got this problem??



sid872
Oct 5, 2007, 10:05 AM
You aren't alone! My Top 25 Most Played list is completely different on my Touch than on iTunes (even though the iTunes one is correct). Maybe the touch has trouble recognising playlists relying on play counts???

joefinan
Oct 5, 2007, 10:22 AM
Well, that's crap then!

grask8
Oct 5, 2007, 10:28 AM
You aren't alone! My Top 25 Most Played list is completely different on my Touch than on iTunes (even though the iTunes one is correct). Maybe the touch has trouble recognising playlists relying on play counts???

unless you have exactly the same songs on both then it will be different

Mhaddy
Oct 5, 2007, 01:46 PM
unless you have exactly the same songs on both then it will be different

Aye, that's the point of a smart playlist.

SeanGood79
Oct 5, 2007, 02:13 PM
Just got my Touch (at last).

I have an iTunes playlist called 'Chart' - 200 most-played tracks. However, on that playlist on my Touch it has 200 seemingly random tracks which don't even appear in the original 'Chart' playlist.


I have this problem too, only the songs aren't random, they're displaying my least played songs. I switched the criteria to show my least played songs, sync my Touch, and saw my most played songs in the playlist.

aristobrat
Oct 5, 2007, 02:29 PM
I have this problem too, only the songs aren't random, they're displaying my least played songs. I switched the criteria to show my least played songs, sync my Touch, and saw my most played songs in the playlist.
Wow, that bug is on the Touch, too? It's been on the iPhone so long that I forgot about it. :(

Same solution, too -- set the playlist to show the 25 'least' played songs, which when synced to the iPhone, actually shows the 25 'most' played. :rolleyes:

REBELinBLUE
Oct 5, 2007, 05:10 PM
I've noticed this also, I've also noticed that play counts aren't be synced. Therefore if you play a podcast on the touch, although it is marked as played when you sync, the play count isn't updated and so it is left on the device if you have it set to only sync unplayed podcasts (why does iTunes check for "play count = 0" rather than the "is not new" value though ? :()

I really hope they sort these problems out sooner rather than later

nouras
Oct 5, 2007, 06:43 PM
Yup got an issue with smart playlists as well. Recently added and recently played don't update at all. They stay the same as when I first created em. I've managed to get em updated a couple of time by right clicking on them in itunes (which displays the playlists perfectly btw) and clicking copy to play order and then syncing it (usually a number of times). It's pretty annoying that these playlists don't work- fails as an iPod. Guess it's just a matter of time before 1.1.2 comes out

SeanGood79
Oct 6, 2007, 05:39 PM
I've noticed this also, I've also noticed that play counts aren't be synced. Therefore if you play a podcast on the touch, although it is marked as played when you sync, the play count isn't updated and so it is left on the device if you have it set to only sync unplayed podcasts (why does iTunes check for "play count = 0" rather than the "is not new" value though ? :()

I really hope they sort these problems out sooner rather than later

I've only had playcount issues once, the only time I used iTines wifi. I bought an entire album, played it through, and after syncing to my computer only the third song was marked as played. It also happen to be the only song I gave a star rating to.

tha80sbrat
Oct 6, 2007, 08:09 PM
Yup got an issue with smart playlists as well. Recently added and recently played don't update at all. They stay the same as when I first created em.

Okay, I have that problem too and I thought it was my fault. I was wondering why none of the new stuff is showing up. :confused: