PDA

View Full Version : Some help with xbox live through internet sharing (please help!!)




Angels&Airwaves
Oct 5, 2007, 05:41 PM
I know this is a common problem, but mine seems somewhat unique.

My friends and I are trying to use our Macbook Pros to get Xbox Live in our dorm room at college. We've tried the official Xbox Wireless Router to use the college network, but it won't support it. The IT dept. said the only way was through internet sharing.

We've manually assigned the Xbox with the IP address we find using ifconfig en0 in the terminal and used the +1 at the end for the Xbox's IP address. We also have the subnet at 255.255.255.0 and that works fine. The gateway we use is just the IP address of our Macbook. This all works fine, and the IP address is confirmed when testing Xbox Live.

The problem lies in the DNS. We found our DNS server numbers through the Macbook and through the IT dept, but when we manually assign these, it still won't confirm it. Is there something that needs to be done through the System Prefs to get this to work? We've tried a lot of things like turning off DHCP and assigning the computer with another IP address, but nothing works.

Can someone walk us through step by step and/or give us some screenshots of what our settings need to be in System Prefs?

Any help is greatly appreciated, we're extremely frustrated at this point and we've tried nearly everything.

Also, would getting XP and running boot camp possibly help compatibility problems with the Xbox?



2nyRiggz
Oct 5, 2007, 05:54 PM
Have you turned on internet sharing?
Are you sharing your connection through the airport? Is this turned on in sys pref?

Check this thread out...it might help you.

http://forums.macosxhints.com/showthread.php?t=30830



Bless

Angels&Airwaves
Oct 5, 2007, 06:03 PM
Have you turned on internet sharing?
Are you sharing your connection through the airport? Is this turned on in sys pref?

Check this thread out...it might help you.

http://forums.macosxhints.com/showthread.php?t=30830



Bless

yes we have turned on internet sharing. the xbox recognizes that it is wired through the macbook. we are sharing a connection through ethernet. the macbook uses airport for internet signal and the xbox is connected via an ethernet cable. when testing the connection the ip address test is confirmed but the dns test fails. i dont what we can do in the system prefs to fix this. we would love for this to work and we know it is possible because some guys in another dorm figured it out but they are using a pc...

2nyRiggz
Oct 5, 2007, 06:16 PM
I have my xbox360 running through my ibook so I know whats up.....Did you follow the link I provided?

Riped from the site:

First off, get all the hardware setup. This is probably the easiest part. Take the cable that comes with your Xbox (or any network cable that fits) and connect it to the back of your Xbox and your Mac. Turn on the Mac and the Xbox (not necessarily simultaneously; probably turn on your Mac first). When your Xbox is on, head to the Xbox dashboard.
On your Mac, head over to the System Preferences and click on “Network.” From the “Show” menu, select “Built-in Ethernet” and set “Configure IPv4? to “Off.” Now head back to System Preferences (click “Show All”) and then go to “Sharing.” Click on the “Internet” button and check the box next to “Built-in Ethernet.” Make sure “Share your connection from: Airport” is selected as well.
Open Terminal (if you can’t find it, just type “Terminal” in Spotlight) and type in the following exactly: ifconfig en0. Hit enter, and it should return something like inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255. If the first IP is something other than 192.168.2.1 make note of it, and don’t close Terminal.
Now, turn around and grab your Xbox controller. Go to the Network settings, and set the IP Configuration to Manual, the IP to 192.168.2.2, the Mask to 255.255.255.0, and the router/gateway to 192.168.2.1 (the IP that I told you to make note of earlier — if yours is different, input that IP instead).

I'm guessing this is the part thats freaking you out...

Get back on your Mac, go to Terminal, and type in dig and hit enter. There will be a lot of data, but you need to pay attention to only one line. Near the end of the output, a line will begin with SERVER. That’s the line you need to look at. Find the IP address in that line, and highlight it.
Go to the Xbox and go to DNS Configuration. Set it to Manual, and input the IP that you just found in Terminal as the primary DNS server. Set your PPPoE settings to Off and your Advanced to Automatic.
Test your Xbox Live connection. Provided you followed all the steps properly, you should have a connection.


I went throught the same thing...it didn't catch at first but after I restarted my mac and 360 it worked.


Bless

Angels&Airwaves
Oct 5, 2007, 06:22 PM
I have my xbox360 running through my ibook so I know whats up.....Did you follow the link I provided?

Riped from the site:

First off, get all the hardware setup. This is probably the easiest part. Take the cable that comes with your Xbox (or any network cable that fits) and connect it to the back of your Xbox and your Mac. Turn on the Mac and the Xbox (not necessarily simultaneously; probably turn on your Mac first). When your Xbox is on, head to the Xbox dashboard.
On your Mac, head over to the System Preferences and click on “Network.” From the “Show” menu, select “Built-in Ethernet” and set “Configure IPv4? to “Off.” Now head back to System Preferences (click “Show All”) and then go to “Sharing.” Click on the “Internet” button and check the box next to “Built-in Ethernet.” Make sure “Share your connection from: Airport” is selected as well.
Open Terminal (if you can’t find it, just type “Terminal” in Spotlight) and type in the following exactly: ifconfig en0. Hit enter, and it should return something like inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255. If the first IP is something other than 192.168.2.1 make note of it, and don’t close Terminal.
Now, turn around and grab your Xbox controller. Go to the Network settings, and set the IP Configuration to Manual, the IP to 192.168.2.2, the Mask to 255.255.255.0, and the router/gateway to 192.168.2.1 (the IP that I told you to make note of earlier — if yours is different, input that IP instead).

I'm guessing this is the part thats freaking you out...

Get back on your Mac, go to Terminal, and type in dig and hit enter. There will be a lot of data, but you need to pay attention to only one line. Near the end of the output, a line will begin with SERVER. That’s the line you need to look at. Find the IP address in that line, and highlight it.
Go to the Xbox and go to DNS Configuration. Set it to Manual, and input the IP that you just found in Terminal as the primary DNS server. Set your PPPoE settings to Off and your Advanced to Automatic.
Test your Xbox Live connection. Provided you followed all the steps properly, you should have a connection.


I went throught the same thing...it didn't catch at first but after I restarted my mac and 360 it worked.


Bless
thanks for the help dude i hope this works. were going out right now but once we try this later we will report back about how this works. i appreciate the help. take care and once again...thanks.

Angels&Airwaves
Oct 5, 2007, 10:48 PM
ok so we tried what the link said and we still have had no luck. i think the problem is with the "built in ethernet" configuration in the system prefs. everytime we switch the "configure IPv4: off" like the link says, the ip address test fails on the xbox. weve tried restarting both the macbook and the xbox. any help?

2nyRiggz
Oct 6, 2007, 08:42 PM
So hows your progress?
How about asking the other guy that set it right for a little help.....do you have access to the router to make changes?



Bless

ace198
Oct 8, 2007, 01:59 PM
u need to turn off your firewall. had the same problem.

icecone
Oct 11, 2007, 09:34 AM
do you use proxy server?