PDA

View Full Version : Stuck already! Help (jailbreaking)




California King
Oct 12, 2007, 05:12 PM
The instructions were:

By using the TIFF exploit, we were able to switch a few folder names around and enable the ability to write to the OS's directories rather than just the Media directory. To start the process of extracting, you will want to start up iPHUC in Terminal.

If we've placed the files on our desktop:
cd Desktop
./iphuc

I did the TIFF exploit already and I put the 3 files from Desktop - Jailbreak onto the desktop and I put the folder "opt" onto my root folder. I open up terminal and I copy and paste the lines "cd Desktop ./iphuc" and it just says image not found or something. What do I do?



California King
Oct 12, 2007, 05:27 PM
OK, I got the cd desktop part, but when I go to type "./iphuc" i get this

dyld: Library not loaded: /opt/local/lib/libreadline.5.2.dylib
Referenced from: /Users/username/Desktop/./iphuc
Reason: image not found
Trace/BPT trap

California King
Oct 12, 2007, 05:34 PM
Well I guess I accidently put libreadline.5.2.dylib in the wrong folder.
I put it in /opt/local/lib/libreadline.5.2.dylib and now I'm getting this when I type in "./iphuc"

iphuc 0.6.1 with tab completion.
>> By The iPhoneDev Team: nightwatch geohot ixtli warren nall mjc operator
CFRunLoop: Waiting for iPhone.

EDIT: OK, what I went on doing was plugging in my iPod into my computer and now I'm getting all this text and it looks like it's working, but iTunes popped up and told me to name the iPod like it was new. What do I do? BTW, I entered "getfile /dev/rdisk0s1 iphonefs/rdisk0s1 314572800" before I attached my iPod.

Can someone tell me if Im doing it right?

Alright, the extracting portion is finished and I think I know what I'm doing..haha, I accidently did the extracting thing twice since I thought I didn't do it...I hope that is ok

Well, even though no one really helped me (since no one replied :( I was able to figure this part on my own by typing what I did) Guess it worked...weird..alright, on to my hacking!

California King
Oct 12, 2007, 05:59 PM
DAMN IT! OK, I don't know what I did wrong, but now there's nothing on my iPod and when I open up Independence to do the install SSH thing, it just gives me a bunch of errors like: Error opening file destination for writing and all that What do I do??????????!!!!!!

California King
Oct 12, 2007, 06:08 PM
Can I please get some help? I give up. I just want to restore my iPod, but I cant. I get the Error 18 thing. I tried resetting my settings on my iPod and then trying to restore in iTunes, but it still won't work! Please help

kinchee87
Oct 12, 2007, 06:32 PM
7. Type getfile /dev/rdisk0s1 iphonefs/rdisk0s1 314572800 and hit return. Make sure your iTouch is plugged in via USB. This will take about five minutes so grab something to drink in the meantime. Once complete, there will be a file named "rdisk0s1" in your "iphonefs" folder

8. Add .dmg to the end of the file. It should end up being rdisk0s1.dmg

9. Double click the file to mount it

10. Open the newly mounted Snowbird3A109a.UserBundle drive and open the "etc" folder. Replace the fstab file inside the "etc" folder with the supplied fstab file.
(See discussion for alternate steps to add Installer.app and patch SpringBoard at this point)

11. Unmount the image

12. Back in Terminal, assuming that you've kept iPHUC up and running, type putfile iphonefs/rdisk0s1.dmg /dev/rdisk0s1 and hit return. This will take another minute or so. When it's finished, reboot the iPod Touch. You can do this by holding the sleep and home button. Then turn it off. Then back on. You're jailbroken!

Did you do the above steps?

California King
Oct 12, 2007, 06:39 PM
Did you do the above steps?
Yes. What I think might have been a problem was that when I plugged in my iPod to do the extracting, iTunes popped up and it told me to name my iPod. After extraction was complete, I renamed it to a .dmg file and mounted it, then opened the etc folder and replaced it with the file. After that I unmounted then entered the code into iPhuc after that, it didnt look like it was doing anything so I opened up iTunes and where it told me to name my iPod, I canceled and it ejected my iPod and after that, I tried to open up Independence and it gave me errors so I reseted my iPod and now I am re-syncing and possibly giving up on this hacking thing...I'll consider trying this again if anyone has any clue to what I went wrong. I'd really appreciate it!


*Above was pretty much a step by step thing I did*

kinchee87
Oct 12, 2007, 06:43 PM
IMPORTANT:If you perform a 'Hard Reset' by shutting down the iPod without using the shutdown slider, SSH WILL NOT WORK. If your SSH is not working, try shutting down your iPod the correct way (hold sleep button until shutdown slider comes up, use slider)

How about this step for SSH-ing?

I used these steps: http://www.touchdev.net/wiki/Jailbreak_Guide

California King
Oct 12, 2007, 06:58 PM
I think I know what to do, but can someone please tell me what I should do if iTunes pops up telling you to name your iPod? Is that even supposed to happen?

kinchee87
Oct 12, 2007, 07:10 PM
i believe it did for me. Just ignore it. The iTunes synching is fixed in later steps.