PDA

View Full Version : iPod Hard Drive Upgrade (3G)




voyagerd
Oct 24, 2007, 03:47 AM
I just purchased a 60GB MK6006GAH Hard Drive to replace my 40GB MK4004GAH drive that was originally in the iPod. I read that this should work on other forums. After replacing the hard drive and connecting my iPod to my computer, it goes into Disk Mode, but the image hangs and stops flashing. Using the command diskutil list in the terminal results in this info on the drive:

/dev/disk5
#: type name size identifier
0: testtest *55.9 GB disk5

This shows a partition map name of... testtest?... and no volume formatted

In System Preferences, it displays the drive.
http://homepage.mac.com/ericliskay/iPodHD.jpg

When I try to format the drive in Disk Utility, it hangs for a long time and then gives the error "Bad Descriptor File".

The drive also does not have an Apple symbol on it. Other than that, it looks basically identical to my 40GB drive. The power requirement specs are also listed as the same.

Do you think the drive is damaged? Maybe I have to format it outside the iPod first? Could it be that the drive with Apple's logo are special in firmware or ROM in some way? Ideas? Thanks!



voyagerd
Oct 25, 2007, 04:20 AM
I borrowed my roommate's iPod USB cable and strangely enough, it worked. I could only restore my iPod on 10.5's iTunes though. 10.4 says I need it connected with FireWire. I guess I'll go out and buy a USB cable to transfer music, though I still need FireWire to charge it.

xxstatic
Oct 25, 2007, 01:16 PM
I guess I'll go out and buy a USB cable to transfer music, though I still need FireWire to charge it.

I have had that happen to me as well, I do have one of the original ipod usb/firewire cables.

http://pocketpccentral.net/mp3c/images/ipod/access/usb_firewire_cable.jpg

I keep the fw plugged into the wall and run the usb to the computer.

voyagerd
Oct 25, 2007, 04:54 PM
Oh yeah, I remember those now. They don't make them anymore though. I went and bought a USB cable for it today.