PDA

View Full Version : 10.2.8 sdk gone in leopard




lucas
Oct 27, 2007, 05:00 AM
so I've got some software that I have to very regularly compile for work obligations (ie. I'm modifying it) that's makefile/source needs the 10.2.8 SDK. sadly this SDK is not included in leopard. I've already tried a find and replace "s/10.2.8/10.3.9/g" but it's not happy with that. is there some way I can install the older SDK on leopard?



Sijmen
Oct 27, 2007, 05:15 AM
I'm not sure about this, but you could try to install the latest Xcode 2 developer preview, which should work side-by-side with Xcode 3 in Leopard.

kainjow
Oct 27, 2007, 10:06 AM
Yep, I think the way to go is to stick with Xcode 2.5.

lucas
Oct 27, 2007, 05:24 PM
thanks, I'll give it a shot on monday when i can use work's bandwidth to grab xcode 2

lucas
Oct 28, 2007, 06:05 PM
I couldnt find xcode 2.5, but I grabbed 2.4.1 and it tells me I cant install it because there's no 10.4 on the volume. do I need a paid developer account (I'm currently using a student one) to get access to 2.5?

edit: so i found a link to it from google, downloading it now. my fingers are crossed

lucas
Oct 28, 2007, 06:41 PM
and no luck :/

I guess I'll have to keep a copy of tiger handy on an external hdd

just rememberd the 10.2.8 sdk is an optional install, but now the installer fails with an unhelpful error message about failing the preflight script :(