PDA

View Full Version : Xcode 3 for Tiger targeting on Leopard?




Sijmen
Oct 27, 2007, 05:13 AM
Hi,

I'm working on a Mac app that needs to work on Tiger. I really like Xcode 3 and Interface Builder 2 that came with Leopard.

If I choose to use Xc 3 and IB 2, using the Tiger SDK in Xc and setting backwards compatibility to Tiger in IB, how big is the chance I'll be hitting major problems with Tiger compatibility? Or is it better to stick with the old Xcode and IB?



kainjow
Oct 27, 2007, 10:04 AM
What OS version do you need to support? 10.4? 10.3 or earlier? If it's only 10.4 you should be fine. Even with 10.3 I think you'd be fine. I believe there is a menu under File (it may have changed) that lets you review any potential problems if you're using properties or controls that don't exist in older versions of the OS. Plus with Xcode you can choose to build for a certain SDK, what you probably want is the MacOSX10.4u.sdk

Sijmen
Oct 27, 2007, 11:51 AM
Jup, only 10.4. Thanks for the info, I think I'll be sticking with the new tools then :cool:

Alloye
Oct 27, 2007, 04:23 PM
I've built a few things for Tiger using the new tools. Just use the 10.4 SDK and pay attention to the warnings from Interface Builder and you'll be fine.

Sijmen
Oct 27, 2007, 06:52 PM
There are some warnings like 'thin splitter style is not supported on < 10.5'. Does that mean: 'your app wil break horribly on those playform' or will it just look like it would without that attribute set?

gnasher729
Oct 28, 2007, 05:38 PM
There are some warnings like 'thin splitter style is not supported on < 10.5'. Does that mean: 'your app wil break horribly on those playform' or will it just look like it would without that attribute set?

I think the answer to that is that you definitely need a computer with 10.4 installed, unless you have an excellent test department that will find all problems.

Sijmen
Oct 28, 2007, 05:50 PM
It seems the external harddrive with Tiger isn't optional then. Thanks for the suggestions.