PDA

View Full Version : target disk mode




laidbackliam
Oct 31, 2007, 07:09 PM
how does get out of target disk mode? i can't restart my g4 back to normal boot mode...

any ideas?



Eidorian
Oct 31, 2007, 07:10 PM
http://www.google.com/search?q=target+disk+mode

http://docs.info.apple.com/article.html?artnum=58583

laidbackliam
Oct 31, 2007, 07:22 PM
yeah, i tried those, didn't work so well. even if i try to boot into a cd it goes back to firewire disk mode.

kind of freaking out, need to use it as my home server.

any idears?

Eidorian
Oct 31, 2007, 07:25 PM
So it's going back into Target Disk Mode even though you don't want it to?

Have you tried holding down "Option" after the boot tone and picking your boot partition?

laidbackliam
Nov 1, 2007, 01:28 AM
yea. it just locks up at that point.

a strange boot screen with mac osX shows up. but then the mouse pointer shows up and does hte old school mac watch image. i let it hang for 20 minutes before just shutting the system down.

i may try to start the computer with my friends iBook, but since my macbook pro is intel, i can't do much right now for trying to restart the hard drive.

hopefull someone has an idea of what i can do.

iPhil
Nov 1, 2007, 01:34 AM
Try dragging the targeted unit on the 'main' unit to trash to eject the target unit from the system .. Target disk thru FW is just like having really big flash drive..

disconap
Nov 1, 2007, 02:22 AM
Also, make sure that the version of OSX on the controlling computer is the same or higher release than the target disc, then run disc utility on the target disc. That might help...

laidbackliam
Nov 1, 2007, 01:13 PM
i'm using leopard, the g4 is using 10.4.10

i'm repairing permissions and repairing thedrive using disk utility, then i'm going to drag the disk to the trash (which is how i ejected it earlier too), then disconnect the fw cable from both ends

just to be safe.

laidbackliam
Nov 1, 2007, 01:29 PM
still no luck

this is starting to worry me slightly

laidbackliam
Nov 1, 2007, 01:46 PM
so i'm at the boot screen. i have my leopard disk (i know i can't install it, just needed a disc to put in) and the boot drive showing up.

but i can't select either.

does anyone have an idea? please, i really need to get stuff off of this computer that is not on the main drive. i'm going to shower and let the g4 sit on the boot screen for a bit, that might improve things.

laidbackliam
Nov 1, 2007, 02:26 PM
alright, got back in.

thank the lord.

i had to wait for ages but it finally brought a mouse pointer up. clicked on the next button on the boot screen, and voila, i was back in. not nearly as easy as it should have been though.

at least it works, thanks to everyone who posted with ideas, i truly do appreciate it.

Eidorian
Nov 1, 2007, 02:37 PM
I hope was I able to help somewhat. :(