PDA

View Full Version : hdid command not working on PPC




Sunil
Nov 1, 2007, 02:14 AM
Hi Folks

I made a .DMG file on a PPC G4 Mac-mini & G4 Imac with both tiger & panther installed on it.

The DMG was created through the following command

sudo hdiutil create -size 201m -fs HFS+ -volname "Dummy" /Volumes/Boot/Dummy.dmg

Then i attached a shadow file to the dmg through following command

sudo hdid /Volumes/Boot/Dummy.dmg -shadow /Volumes/Boot/Shadowtrial1


Now the problem starts

The moment i attached the shadow file to the DMG the available space of the drive that was mounted by DMG through the above command was 0kb

But if I double clicked the DMG then the drive that was mounted was showing 197.8MB as available space

This was the case with PPC

But I tried the same steps on a intelmac there the mounted drive was showing 197.8MB even if I mount the drive through the above command

Also on PPC machine if I create Files or Folders on the drive which was attached a shadow & rebooted the machine & after reboot i tried to again attach the same shadow to the drive thropugh the following commad

sudo hdid /Volumes/Boot/Dummy.dmg -shadow /Volumes/Boot/Shadowtrial1

Then I m was able to see the file or folders which I created before reboot i.e the changes are getting lost even if i am retainig the same shadow file .

But i tried same thing on an intelmac & I was able to see the files or folders even after reboot .

So why there is such a great difference batween Intelmac & PPC for a command which is provided by mac.

If any one has any suggestions or any clues then please help me.

Thanks in advance
Sunil Prajapati