PDA

View Full Version : VNC Setup for connecting from XP?




kurtk9
Nov 1, 2007, 11:02 PM
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"

Has anyone had any success connecting via VNC (w/o ARD installed) from XP? If so, what did they do and what XP VNC client?



kurtk9
Nov 2, 2007, 08:35 AM
Has anyone tried VNC w/ Leopard?

taeclee99
Nov 2, 2007, 08:45 AM
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"

Has anyone had any success connecting via VNC (w/o ARD installed) from XP? If so, what did they do and what XP VNC client?

I use Tight VNC to connect to my mac at home (10.5) from work (XP). I could not get real vnc working either. Also make sure that your router allows port forwarding to ports 5900 and 5901.

kurtk9
Nov 2, 2007, 09:05 AM
I just tried TightVNC and I got the following: "Server did not offer supported security type!"

Did you change any of the default options in TightVNC on the Windows machine? My 10.5 machine actually isn't behind a router, but I do have Screen Sharing able to pass through the Firewall.

pb30
Nov 2, 2007, 10:03 AM
I just tried this last night. Ended up using Vine Server on OSX and realVNC on windows

blackscooby
Nov 2, 2007, 10:19 AM
I just tried this last night. Ended up using Vine Server on OSX and realVNC on windows

Exactly what I use. I tried to get the Apple version working but I couldn't find a VNC client that worked with it.
I've also found that Vine Server on the Mini also hangs when you try and reboot and requires me to force quit. This is a pain when I remotely try and reboot as I loose my connection but the Mini doesn't go down :(

kurtk9
Nov 2, 2007, 10:30 AM
Hmm, so you couldn't get past this security issue either? Is Vine Server 10.5 compatible and free?

mountainman
Nov 2, 2007, 11:09 AM
Hmm, so you couldn't get past this security issue either? Is Vine Server 10.5 compatible and free?

Yes, Vine Server is compatible with Leopard & it's free. I have it running on Leopard now with no problems.

l33r0y
Nov 2, 2007, 11:17 AM
Is Leopard screen sharing based on the VNC protocol or is it Apple propriatory?

If it is the latter, I'm not surprised it you can't connect to a Leopard based Mac using a VNC client *without* adding a VNC server on the Mac as well.

taeclee99
Nov 2, 2007, 11:29 AM
I just tried TightVNC and I got the following: "Server did not offer supported security type!"

Did you change any of the default options in TightVNC on the Windows machine? My 10.5 machine actually isn't behind a router, but I do have Screen Sharing able to pass through the Firewall.

I did not change any of the settings in Tight VNC. It just works on mine.

taeclee99
Nov 2, 2007, 11:31 AM
Is Leopard screen sharing based on the VNC protocol or is it Apple propriatory?

If it is the latter, I'm not surprised it you can't connect to a Leopard based Mac using a VNC client *without* adding a VNC server on the Mac as well.

Leopard screen sharing is based on the VNC protocol. It is kinda slow connecting via my windows xp pc from work but it works.

Tracer
Nov 3, 2007, 07:03 PM
The security issue for me was the fact that I had not setup a password for when I tried to connect to my Mac.

You can set it in System Preferences.

You might have to free up a port too, but I don't think so.

Tracer

JYF
Nov 6, 2007, 06:36 AM
I've tried many ways to connect to my home Leopard iMac from my work XP machine over the Internet. No success. :(

Has someone managed to do this ? If so, can you detail every step to achieve this ? (Mac preferences to check, XP software to use, etc.)

Tutorial badly needed here ! ;) Thanks a lot for any help...

sebf
Nov 6, 2007, 07:11 AM
I've tried many ways to connect to my home Leopard iMac from my work XP machine over the Internet. No success. :(

Has someone managed to do this ? If so, can you detail every step to achieve this ? (Mac preferences to check, XP software to use, etc.)

Tutorial badly needed here ! ;) Thanks a lot for any help...

I found that its just a case of opening the ports (on your internet router/hardware software firewall see: http://portforward.com for details) and setting up a VNC password.

Only problem I have been having is that the new Leopard VNC server doesn't seem to support compression/quality settings so every time I connect over the internet it loads my mac in true color at 1600x1050 res which takes about 2/3 mins just to download the initial screen (let alone trying to control the bloody thing!). I think I might disable the built in VNC as it doesn't seem to support different quality/compression and go back to using Vine VNC server!

huzur
Jan 30, 2008, 08:57 PM
I just got RealVNC working

- Turn off Render Cursor Locally
- Set color to full color

and it works. Took a ton of trial and errors playing with different options in RealVNC 4.1.2 to get it to work :)

jgp1231
Feb 29, 2008, 01:36 PM
I just got RealVNC working

- Turn off Render Cursor Locally
- Set color to full color

and it works. Took a ton of trial and errors playing with different options in RealVNC 4.1.2 to get it to work :)

Thank you very much. That worked for me. I'd been messing with this and was getting nowhere until I found your suggestion.

mgroff
May 18, 2008, 09:41 AM
I doubt anyone is watching this anymore, but I wanted to thank huzur again for that workaround! I'd wasted a couple of hours on this and was getting nowhere. Huge help!

metavalent
Jul 11, 2008, 06:37 AM
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"


People still watching this thread and still having EXACT same issues with both these viewers. :confused:

The mouse cursor workaround that has helped for others has not worked here; at least not on XPSP3. Seems rather annoying to have to install Vine when Leopard advertises that this should work out of the box. Will keep trying and report back if I find another workaround. Thanks for all the work in this group!

manman
Sep 14, 2008, 06:02 PM
I have been able to get both UltraVNC and TightVNC to work using the settings people have given here. My question is- is there a reason it doesn't work with different settings? Setting it to anything other than 'full color' the window just shuts down when you log on. But at full color the connection is INCREDIBLY slow, even from within the same house.

Is there any way to get it to work with the settings for a lower connection speed, or any other way to make it faster?

balt
Mar 5, 2009, 07:55 PM
Hi all,

I actually registered on this forum just to post this solution. I hope it will make many others happy!

Motivation for going through these hoops:
I needed to access the desktop of an old OSX machine every now and then from a windows VNC client. Details of that machine are:
Dual G5 OSX 10.4 without monitor/keyboard.

Important:

- Remote Desktop had never been enabled before on that machine.
- SSH access however was available.

So how do you turn on Apple Remote Desktop / VNC Server on a machine where it never ran before? That part was easy to find on the net: SSH as an admin user onto the OSX machine. Then execute this command:

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users admin -privs -all -restart -agent

Try to connect with your VNC client now. If it works, good, you're done. The above command takes care even of restarting the Remote Desktop Service when the computer is rebooted.

But if you're not so lucky (like I was) and the connection fails with a message like:
- "Server did not offer supported security type" (tightVNC)
- "No matching security types" (realVNC)
- "Incompatible Version" (UltraVNC)

you're stuck. What happened in this case is that the VNC password has never been setup properly. Follow these simple steps while still logged in as admin user to set up a default password ("pass" in our case):

- Switch off RDP:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -stop

- Go to the Preferences directory:
cd /Library/Preferences

- edit the following files using vi (if you're not familiar with vi, be very careful to follow the instructions to the iota!):
sudo vi com.apple.RemoteManagement.plist

Put the following lines into this file (hint: copy them from here rather than typing them). Instruction for vi newbies:
- copy the text below into your clipboard
- set focus to the ssh window
- press the 'i' key. This puts vi into text insert mode
- paste the text. If you're on windows/cygwin, click to top left of the cygwin ssh window -> Edit -> Paste
- press the 'Esc' key
- enter the keystrokes ':wq', colon tells vi you are about to enter a command, w is the command for write, q for quit.

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0">
<dict>
<key>ARD_AllLocalUsers</key>
<false/>
<key>LoadRemoteManagementMenuExtra</key>
<true/>
<key>ScreenSharingReqPermEnabled</key>
<true/>
<key>VNCLegacyConnectionsEnabled</key>
<true/>
</dict>
</plist>

- edit the file sudo vi com.apple.ScreenSharing.launchd
press the 'i' key and type enabled, hit return, 'Esc' and ':wq'

- set the default VNC password to 'pass' by editing this file:
sudo vi com.apple.VNCSettings.txt
and copy/paste this string (the encoded password) into that file: 6755221D8BA8C5E2FF1C39567390ADCA

- Now the files need to have their ownerships and access rights configured properly. Do this by executing the following commands after each other:

sudo chmod 644 com.apple.RemoteManagement.plist
sudo chown root:admin com.apple.RemoteManagement.plist

sudo chmod 644 com.apple.ScreenSharing.launchd
sudo chown root:admin com.apple.ScreenSharing.launchd

sudo chmod 400 com.apple.VNCSettings.txt
sudo chown root:wheel com.apple.VNCSettings.txt


Now stop and start the Remote Desktop Server, or reboot the machine:

To just restart the Remote Desktop first stop it:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -stop

Then restart it:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users admin -privs -all -restart -agent

or, alternatively, reboot the server:

sudo shutdown -r now

Connect to the server and enter your password we set to "pass" above. Set the password to something else by opening the System Preferences -> Sharing -> Apple Remote Desktop -> Access Privileges and set the password in the "VNC viewers may control the screen with password:" to something else.

:apple:ED

Hope this helped!

Cheers

Balt Indermuehle <balt@inside.net>

prosynk
Jun 8, 2009, 09:40 AM
Hi all,

I actually registered on this forum just to post this solution. I hope it will make many others happy!


Hope this helped!

Cheers

Balt Indermuehle <balt@inside.net>

ANd I joined this forum to thank you for the first workable answer I've come across since re-installing OS X on my home machine. Got to work today and tried to VNC in, but I continuously got the Security incompatibility problem. I ssh'd in, and your solution worked perfectly.

Thank you!

dung
Jul 11, 2009, 03:04 PM
Balt your instruction is great thanks it works perfectly!
Dung.

ick
Nov 29, 2009, 03:10 PM
Balt, I also just registered here to thank you. I'd been stuck for hours, and your solution worked like a charm.
--Ick

bml104
Dec 8, 2009, 01:04 PM
Searched all over for this since upgrading to Snow Leopard. It worked like a charm. However, I did have to use the following command

echo -n enabled > com.apple.ScreenSharing.launchd

before the com.apple.ScreenSharing.launchd would show up.

cFoo
Jan 4, 2010, 01:28 PM
I'm still stuck. I tried both balt and the cursor methods. Still the same error. "Server did not offer supported security type"

I'm on Snow Leopard (64 bit) and Winblows. I desperately need to access my Mac remotely but Apple is making it nearly impossible. I've searched everywhere! I know it's not my connection because I can VNC into my Ubuntu box without any problem (on a different port).

If anyone has any other idea please chime in! I've been trying this for a week already. It took me less than 5 minutes to get it working on Ubuntu.

mgroff
Jan 7, 2010, 11:19 AM
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"

Has anyone had any success connecting via VNC (w/o ARD installed) from XP? If so, what did they do and what XP VNC client?


I believe the security error you're seeing is actually just a bug and might be owing to your screen resolution. Here are settings which worked for me (NOTE: I state they worked--this is technically correct, but the performance was so hideous that you might find the term debatible)

[Options]
UseLocalCursor=0
UseDesktopResize=1
FullScreen=1
FullColour=1
LowColourLevel=1
PreferredEncoding=ZRLE
AutoSelect=1
Shared=0
SendPtrEvents=1
SendKeyEvents=1
SendCutText=1
AcceptCutText=1
DisableWinKeys=1
Emulate3=0
PointerEventInterval=0
Monitor=
MenuKey=F8
AutoReconnect=1

Good luck,

Marcus

ssbarnea
Jan 13, 2010, 08:36 AM
I have a little bit different issue connecting using VNC from Windows to OS X

Pressing the Insert key does put mac VNC server in a keyboard locked mode.

See below:
http://superuser.com/questions/94326/how-to-prevent-question-mark-cursor-issue-cause-be-insert-key-when-doing-vnc-to-a-mac

mkormendy
Jan 13, 2010, 11:30 AM
When you go to edit com.apple.RemoteManagement.plist with vi, and you notice that there is content already in the file, place the code supplied BELOW/AFTER the content, on a new line.

As well when you go to try and edit com.apple.ScreenSharing.launchd wuth vi, it may be helpful to unhide the file from an ls command with this:

echo -n enabled > com.apple.ScreenSharing.launchd

FINALLY, after your system reboots, BEFORE trying to remote administer with VNC, go into the System Preferences panel, click Sharing, then go to the Remote Management item. Click the Computer Settings button, and from the drop-down, select 'VNC viewers may control screen with password:' and enter your new password.
MAKE SURE you deselect "Anyone may request permission to control screen".

Hit OK.

I suggest a reboot one more time, and then try logging in with VNC.

Works for me now!

radiowhiz
Jan 26, 2010, 09:32 AM
Hi There,

I was reading this thread and its not clear to me whether "balt"'s solution has overcome the need to run full color or not? can someone please comment?

I can use tightvnc and realvnc at full color only using hextile encoding. The moment I deviate from hextile / full color settings, I get the security type not supported.

Thanks,
RW

robertk54
Feb 8, 2010, 01:02 PM
I have a related issue. We bought a Xserve with Mac OS Server assuming this was similar to a Windows Server. However, unlike Windows Server it does not support multiple simultaneous users. We want to use this as a development platform allowing collaboration using a common software database.

I have done some investigating and discovered a workaround. Using Vine VNC server in place of the built-in VNC server enables this. Problem is, each user must first log in to the system using a directly connected terminal and then manually (or automatically) start the Vine VNC server before they can connect remotely to their unique session. Has anyone come up with a simpler solution? I tried running the Vine VNC server from a normal VNC session and this appears to be disallowed since it never starts.

jvuz
Jun 10, 2010, 05:13 AM
I solved it by doing the following: Goto System Preferences-Sharing-Screen sharing-Computer settings
Check the checkbox for 'VNC viewers may control screen with password' and you enter the correct password for VNC.
That worked for me. Hopefully it can help you guys/girsl to.

Jvuz

ncprius
Nov 2, 2010, 05:53 PM
If your keystrokes are un-encrypted, and/or you rely on a single vnc password to gain access to a computer, then you are asking to be hacked.

See http://reviews.cnet.com/8618-13727_7-10329122.html?communityId=2123&targetCommunityId=2123&blogId=263&messageId=10022412&tag=mncol;tback

Tutorial: Screen Sharing in Leopard (Mac OS X 10.5): How it works and how it doesn't.

In a nutshell, from windows or linux wanting to operate a mac remotely, any IT person with an inkling of security concerns needs to use an ssh tunnel and block ssh attacks. Otherwise, you are making it easy to break into your mac: a brute-force password attack on your vnc server and they own it. There are tons of kiddy hacker scripts to do this.

ajalro
Apr 6, 2011, 07:37 AM
Hello to all,

I'm trying to connect to my imac at home from my windows-pc at work but when I launch the viewer (realvnc or ultravnc) giving my dyndns imac-home address I receive this message:
connection failed - invalid protocol
possible causes:
- you've forgotten to select a DSMPlugin and the server uses a DSMPlugin
- viewer and server are not compatible (they use different RFB protocols)

what should I have to do?

supermariofan25
Apr 26, 2011, 08:49 PM
I'm still stuck. I tried both balt and the cursor methods. Still the same error. "Server did not offer supported security type"

I'm on Snow Leopard (64 bit) and Winblows. I desperately need to access my Mac remotely but Apple is making it nearly impossible. I've searched everywhere! I know it's not my connection because I can VNC into my Ubuntu box without any problem (on a different port).

If anyone has any other idea please chime in! I've been trying this for a week already. It took me less than 5 minutes to get it working on Ubuntu.

are you able to install 3rd party software on it? if you can try a different vnc server:)

supermariofan25
Apr 26, 2011, 08:57 PM
@CFoo if you are using snow leopard you may have to do what this guy did using balt's method if you can't install 3rd party vnc software:)

When you go to edit com.apple.RemoteManagement.plist with vi, and you notice that there is content already in the file, place the code supplied BELOW/AFTER the content, on a new line.

As well when you go to try and edit com.apple.ScreenSharing.launchd wuth vi, it may be helpful to unhide the file from an ls command with this:

echo -n enabled > com.apple.ScreenSharing.launchd

FINALLY, after your system reboots, BEFORE trying to remote administer with VNC, go into the System Preferences panel, click Sharing, then go to the Remote Management item. Click the Computer Settings button, and from the drop-down, select 'VNC viewers may control screen with password:' and enter your new password.
MAKE SURE you deselect "Anyone may request permission to control screen".

Hit OK.

I suggest a reboot one more time, and then try logging in with VNC.

Works for me now!

gburdett
Oct 21, 2011, 11:34 AM
I set up "screen sharing" on the Mac as described on this page:
http://www.trickyways.com/2010/06/how-to-remotely-access-mac-from-pc/

I initially had the same issue, with the "no matching security types" message, then I returned to the Mac setup preferences form and hit the button "Computer Settings", where I set up a password for the screen sharing. Once I did that, I was able to log in to the Mac from TightVNC on Windows 7, with no further config changes.

The TightVNC installer claimed to have made a firewall exception on Windows. If it is not working, then it would be a good idea to check that the exception is actually there.

Greg Burdett