PDA

View Full Version : Help, G4 MDD dual 1 GHz - startup disk




rush4411
Dec 12, 2007, 11:23 PM
I recently lost my G4 MDD 1.25 GHz tower to a power surge. I've replaced it with a G4 MDD dual 1 GHz. This is a dual boot machine. When booted up in 10.4.11 I can select the 9.2.2 disk but it will restart on 10.4.11 - Selecting Target Mode, it will boot on 10.4.11. The only way to boot 9.2.2 is with an Option start. When in 9.2.2 and using the Startup Disk control panel and choosing 9.2.2 - it boots up from the 10.4.11 disk. Additionally, when a Tiger DVD is inserted and the Install and Restart are clicked - it boots up the 10.4.11 disk.
I installed 10.4.11 and 9.2.2 on two partitions of another hard drive - same results. I Reset-all in Open Firmware. Pressed the PMU reset. I'm out of ideas.
I really hope I'm not the only one to experience this.



MacsRgr8
Dec 13, 2007, 03:33 PM
It seems that writing the Startup disk choice to PRAM doesn't work...

Does it boot from the first HD found (Disk0), or does it always boot from a Mac OS X partition?
Have you tried installing Mac OS X on the current Mac OS 9 partition, and vice versa, just to find out what will happen then... Will it "always" boot Mac OS 9, or Mac OS X as it does now...?

rush4411
Dec 13, 2007, 08:27 PM
I want to make sure I understand your terms. Is disk (0) the inner disk to the rear of the tower?

rush4411
Dec 13, 2007, 08:30 PM
I also discovered that when choosing Target Disk Mode, that computer boots up on the same 10.4.11 system. Booting up with the "T" key down works okay.

CanadaRAM
Dec 13, 2007, 08:33 PM
Have you replaced the PRAM battery yet?

Sun Baked
Dec 13, 2007, 08:36 PM
Have you replaced the PRAM battery yet?

I know Radio Shack used to carry them, and generally are closer to people than most Apple Stores.

rush4411
Dec 13, 2007, 09:57 PM
Your suggestion yielded some results. I put a copy of 9.2.2 on the same partition as 10.4.11. When I selected that system, sure enough it booted with that system 9.2.2 Then I selected the System on the other partition. Instead it booted up on the system I put on the 10.4.11 partition. It would appear that the computer is only selecting a system on that one hard disk. For what it's worth, these drives worked fine when in my G4 MDD 1.25 GHz Computer.
As to the suggestion from CanadaRam. I can do that, but I thought that the battery only came into play when the computer was unplugged. Am I wrong?
In Sys 9 we used to be able to Zap the PRAM. Is that an option?

rush4411
Dec 15, 2007, 03:06 PM
A clarification for MacsRgr8 - With Sys 9.2.2 and Sys 10.4.11 on the same partition, the Startup disk selection works properly in both systems - but only with the systems on that partition. Selecting a startup disk from a different Hard Drive results in booting up with the last system chosen on Partition containing both systems.

Changed the Battery - No change.

Blogger
Dec 15, 2007, 09:17 PM
Is the System on the second drive blessed?
If not, you can't boot from it. Easily fixed if that's the problem.

rush4411
Dec 15, 2007, 10:36 PM
Using an "Option" start, I can boot from any system on any partition. Just the Startup Disk doesn't work on either System.

Blogger
Dec 15, 2007, 11:19 PM
OK, just as an experiment, try deleting (in OSX):

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist

ReanimationLP
Dec 15, 2007, 11:21 PM
I know Radio Shack used to carry them, and generally are closer to people than most Apple Stores.

We still do.

In fact, now the packages say for Apple Macintosh computers. :D

But yeah, it sounds like your battery is on the fritz.

rush4411
Dec 16, 2007, 01:07 PM
Don't seem to have a file in that folder named:
Library/preferences/sys configuration/com.apple.boot.plist

In the sys configuration folder i have:
com.apple.nat.plist
com.apple.PowerManagement.plist
NetworkInterfaces.plist
preferences.plist
preferences.plist.system_default

Is it significant that the same fault occurs when booted in 9.2.2?

Blogger
Dec 16, 2007, 06:36 PM
Sorry rush4411, I forgot that you weren't running Leopard.

That's an odd problem. Incidentally, you can still Zap the PRAM in OSX, it's done in exactly the same way Cmd, Opt P,R. Give it a try, it can't do any harm.

If that doesn't work and you've tried the OF resets, I don't have much else to suggest. The really odd thing is it happening across both OSs. Is it possible that some form of directory corruption could be the cause? If you have access to DiskWarrior, I'd give it a try too.

If you do find a solution, let us know what it was.