PDA

View Full Version : iMac G4 Freezing


tek
Sep 30, 2003, 05:11 PM
My iMac G4 is doing something rather odd... at random intervals (only does it in OS X)

It will suddenly freeze. Music stops playing, clock stops etc. but the mouse still moves. Once the mac eventually goes to sleep, it will wake, music will return and it will be fine. I'm using Mac OS 10.2.6

My comp is a 700mhz 15" iMac G4 with 640mb ram

Anyone got any suggestions? I think it is a software issue, because OS 9 never does this. It's only just started happening and there is no applecare left on this machine. I have tried reinstalling OS X (agh it takes ages.. first OS 10.1 then the 10.2 upgrade)

It freezes in both 10.1 and 10.2 like this, but not OS 9.

Marlon_JBT
Oct 1, 2003, 07:03 PM
Hey, my 12" PB does this too!

What's up?

tek
Oct 2, 2003, 10:07 AM
just done it again... its so frustrating :mad:

tomf87
Oct 2, 2003, 10:51 AM
This may or may not help.

Try leaving Terminal open and running 'top'. Or use Process Viewer.

Leave these app(s) where you can see them and when it locks up, maybe you will notice an app that's using all CPU resources.

tek
Oct 2, 2003, 11:37 AM
that's the odd thing about it. no app is crashing. things are still "processing" while this happens - if i download something it still downloads/saves etc. while its frozen, and AIM will send autoresponses etc.

It just seems that its not responding to any input from kb or mouse (mouse moves but clicking/hovering over does nothing) and the image on the screen appears frozen (does not update)

I'll try it though

tek
Oct 3, 2003, 03:01 PM
it's just done it again...

it wont accept any new SSH connections once its frozen, but it will reply to pings...

chicagdan
Oct 3, 2003, 03:18 PM
My iMac G4 was doing the same thing under 10.2.6 ... fortunately it stopped doing it once I installed 10.2.8. Of course, getting 10.2.8 installed was a nightmare, but now that it's in, the computer is running much, much better. Bottom line, I think 10.2.6 was a very bad update.

tek
Oct 3, 2003, 03:48 PM
hmm... maybe i'll try updating again :)

it did it 24/7 in 10.1, then seemed to stop until recently in 10.2... maybe it was the 10.2.6 update which started the problems