PDA

View Full Version : Artists not showing up on ipod




easports5001
Dec 15, 2007, 02:11 AM
Some artists are not showing up on my ipod classic, when i choose Music> Artists, why is this happening?? Help please.



mad jew
Dec 15, 2007, 10:01 PM
What are the artist names?

easports5001
Dec 15, 2007, 10:10 PM
Actually about half of my artists are not shown when I choose Music>Artists, but I noticed this incident when I couldn't find Tom Petty & The Heartbreakers.

mad jew
Dec 15, 2007, 10:13 PM
Strange. Does the amount of space used on your iPod match the amount of space you'd think your collection should take up? In other words, does it look like the songs are there but not listed in this menu? Can you find them using a different route? If so, maybe try resetting your iPod by holding the top of the clickwheel and the middle button down for ten seconds or so.

easports5001
Dec 15, 2007, 11:05 PM
The songs can be found when you look for them under "Songs" and "Albums" so they are definitely on the ipod. But when I try to use search to find them they don't get displayed.

I reseted the ipod and its still the same, I even restored the ipod and that didn't work either.

Anymore suggestions??

wsthornton
Dec 16, 2007, 03:32 PM
I had the same problem after I updated my ipod firmware -- very frustrating. The resolution was to go to the main menu on your ipod, click Settings, click Music Menu, and make sure "Compilations" is NOT checked. Apparently the Compilations setting provides us the ability to browse compilations separate from artists. That would be pretty handy, but a bunch of my CDs must have been categorized incorrectly as "compilations" so it was throwing half my library in there.

I hope this fixed your problem.

bleedinghand
Dec 17, 2007, 07:21 PM
Maybe your songs' ID3 information didn't contain the artist name.

try some ID3 editing tools to fix those songs. probably it works.

hope I could be help.

crothy
Jul 15, 2008, 07:45 AM
I wanted to bump this thread because I'm having the same problem and the compilations issue didn't help. Are there any other suggesstions to fix this? Oh, and what exactly does the ID3 stuff mean? Eh, I'll do a search but any help would be great....

MusicMan7
Mar 28, 2011, 07:23 PM
I had the same problem after I updated my ipod firmware -- very frustrating. The resolution was to go to the main menu on your ipod, click Settings, click Music Menu, and make sure "Compilations" is NOT checked. Apparently the Compilations setting provides us the ability to browse compilations separate from artists. That would be pretty handy, but a bunch of my CDs must have been categorized incorrectly as "compilations" so it was throwing half my library in there.

I hope this fixed your problem.

Thanx, that definitely solved the problem!!

Loukaniko
Nov 13, 2011, 04:16 PM
What I did that worked for me is go to Settings>>Music>>Turn "Group By Album Artist" Off. Hope it works!

prijecttimmy
Nov 25, 2011, 09:43 AM
Here's the stitch.
If you're still having the problem, here is the solution.

iTunes allows you to edit the ID3 tag, but for some reason if there isn't already a title tag in the song, the title tag for that song in itunes becomes the FILENAME not the title tag.

What you have to do is, manually edit the title tag on your computer or with an external ID3 tagger software, the title tag IS NOT the file name.

In windows you can do this by; Right clicking the song, clicking properties and clicking details.

Make sure to have written the 'Title' and 'Album Artist' tags, the rest don't officially matter as you can change them later through iTunes. You can also change 'Album Artist' in iTunes, but do this before as a precaution.

No idea on mac as I don't use one lol.

Then upload to your iPod or iPhone, and it will be solved.

I hope this helps anyone, I have musical OCD and this really pissed me off.

Thanks.

- Timmy :)

Swansonca
Mar 7, 2012, 08:15 AM
Had the same issue. Did the above-mentioned iPod menu change (to do with compilations), then went into the playlist for my iPod, selected all songs, clicked info, and found under one of the tabs a box to click "this is part of a compilation" or something like that. Un-checked for all, and now all my albums show up under their respective artists!

Bruce B
Mar 14, 2012, 05:09 PM
I have both the artists and titles on my ipod but when I go to one of the playlists I've loaded to it, it only displays the song name, unless I hit "play", and then both show up. How do I get it to display both artist and title in a playlist? if it takes two lines or scrolls, that is OK....

quinettaw02
Mar 14, 2012, 10:15 PM
http://www.*******.info/avatar1.jpgI reseted the ipod and its still the same, I even restored the ipod and that didn't work either.