PDA

View Full Version : Not displaying artist under "Artist" menu




blahblahmoo
Dec 27, 2007, 07:59 PM
I have an 80gb ipod classic that I received for Christmas that is not displaying all of the atists that I have uploaded under the "Artist" menu. All of the albums for these artists show up under the "Albums" menu, and all the songs play fine. It's just that I can't search for them under the "Artist" menu.
I have already made sure that all of the info for these files is correct, and by correct I mean I filled in the artist, album, genre, etc. on the ID3 tags. I have tried deleting them off of the ipod and resyncing them and that still doesn't work. I have tried deleting them completely off of Itunes 7 and the ipod and then reuploading them and that doesn't work. Any ideas as to how to fix this?



LinuXtreme
Jan 7, 2008, 10:13 PM
I'm having the same problem. I'd be surprised if this question hasn't been answered elsewhere here on MR. If I find the relevant article(s) I'll post the links here. Otherwise, I'm anxious to hear as well.

I think the problem has to do with artists in compilation albums. I've noticed that many of my "missing" artists are comprised solely of songs that I have tagged as "part of a compilation album" (so that I don't have multiple entries in CoverFlow). It seems to work OK in iTunes, but when it comes to the Classic... I hope Apple finds a fix soon so that we can have our cake (er, CoverFlow) and eat it too.:p

Cinematographer
Jan 7, 2008, 11:41 PM
If you have tagged the album as part of a compilation, the artists are meant to not appear under artist. That's why you've tagged them this way.

I have got the problem the other way around: on the iPod touch, the artists inside the compilations are still listed. And that one is the real bug. I'm sure Apple's going to fix this with the next update.

TinPigeon
Aug 1, 2008, 03:22 AM
If you have tagged the album as part of a compilation, the artists are meant to not appear under artist. That's why you've tagged them this way

I'm not sure I agree that this is how it's supposed to work. Why would it be desirable to obfuscate the artist of a track just because it's part of a compilation? I experience this "bug" on my 80gb Classic, too. It "bugs" me because when browsing for a song, perhaps I remember the name of the artist and not the name of the compilation they may be on.

I've tried many different combinations of checking Compilations, and making the Album Artist = "Various Artists" to no avail.