PDA

View Full Version : Powerbook G4 (DVI) Not boot up - HDD failed




hz1510
Dec 29, 2007, 09:41 PM
Hi,
I have a Powerbook G4 DVI. When I turn it on, it stops at the grey screen. I suspect that the hard drive is broken because the hard drive does not power up when I plug it in a PC with an USB external box. I replace the HDD with a new blank HDD. It does not work, stopping at the grey screen again. But if I unplug the HDD (both broken HDD and new HDD), I can boot using Mac OS X tiger installation CD. With the HDD, I cannot boot up, even with Apple Hardware Test CD, stopping at blue screen with the Apple at the centre.
Please help if you know what happens?
All the best,
Pham



Makosuke
Dec 30, 2007, 08:25 AM
Well, what you're describing SHOULD work just fine--you should be able to install the new HD, put the OS disc in, boot from that, format the drive, and install.

Normally, I'd say it sounds like both the hard drive and the optical drive are set to master (or slave), and that's why it won't boot with both connected... except with laptop hard drives they're almost always set to master so I can't imagine that it'd be different with the new one, and I'm not even sure they're on the same bus in that machine.

I'm a little baffled if it won't even boot to the hardware test with the new drive installed. One thing to try: Boot into Hardware Test without any hard drive attached (I assume that works) and see if you get any errors--it's possible, if the old drive died violently, that it broke the whole bus, so the computer is choking with anything attached to it.

Other questions: How big is the new drive? I would think that if it was over 128GB it'd just be clipped to that capacity, but that might cause issues at least in theory.

Also, if you put the new drive into your USB case and connect it to your other computer, does it work ok? Just to confirm that you didn't get a DOA drive... or that your PowerBook is killing every drive you connect to it.

Maybe somebody else will have better suggestions.

SuperCompu2
Dec 30, 2007, 02:48 PM
Does it have jumpers? It may be getting confused with the Slave/Master setting on the drive and hanging while trying both.

also, i have had people put HDs in upside down before. Could this be the case as well? I know full size ATA connectors have the little slot thing, but i have seen 2.5's jammed in before.

hz1510
Dec 31, 2007, 05:37 PM
Many thanks for your suggestions, Makosuke and SuperCompu2.
Both the HDDs are set to Master (no jumper). I have tried to put the new HDD in a USB box, plugging in the powerbook. I boot the powerbook up with this external USB HDD and without Internal HDD. It works but Mac OS installation software does not allow me to install Mac OS on the external USB.
When booting the powerbook with Apple Hardware Test CD without internal HDD, the programme does not find any error with my powerbook.
I could run the Open Firmware and reset nvram, attemp to boot the powerbook from the internal HDD (using "boot hd:" or "mac-boot") or browse the HDD (using "dir hd:"). It always stops responding when I do those.
There is a thin cable with a thin and square-shaped connector to connect the HDD to the motherboard. Because it is very tight, it is difficult to connect the HDD in a up-side-down position.
Do you have any other ideas?
Happy New Year.
All the best,
Pham

superbovine
Jan 1, 2008, 02:54 PM
Can you hear the new HDD spin up?

Is it a known good hdd have you tested in another system?

Is the orientation you are mounting the HDD set the pin to hook up correctly to pin 1 of the mylar cable connection? I don't remember, but I don't think the connector is keyed so it is possible hook it up backwards.

Makosuke
Jan 2, 2008, 04:53 PM
Well, hz1510, since the drive is ok in an external case, there are really only two possibilities I can think of:

A) Your laptop's ATA bus for the hard drive is fried (I assume it would have happened when the old drive died).

B) That particular drive is not compatible for some reason.

B is uncommon but theoretically possible, especially with an older laptop. You haven't said what brand of drive it is or how large, but if it's over 128GB, that's one possible source of problems. You could also go to XLR8YourMac's Drive Database:

http://forums.xlr8yourmac.com/drivedb/search.drivedb.lasso

...and see if your particular model shows up there, and if others have had trouble getting it to work. It's a nifty resource with obscure compatibility problems.

Really the only other thing to try is get another drive (preferably a smallish, older one just to be sure) and try it--if it does the same thing, then must be the computer. If not, must just be the particular drive you bought.

hz1510
Jan 10, 2008, 04:31 AM
Many thanks, mates
The new HDD works well as an external USB HDD when I plug it in a PC. I have checked the connector. It is impossible to hook up in any other ways.
Makosuke might be right. There should be some thing wrong with the ATA bus. I cannot boot the laptop using Mac OS installation CD. But I can start the laptop by using Ubuntu 6.10 for Powerbook. However, Ubuntu cannot detect the new HDD. It is strange that the diagnosing programme does not detect any problem with the laptop. The new HDD is Samsung 40GB MHXXXXXXX, the same brand and size as the broken one.
All the best,
HP