PDA

View Full Version : Buzz when power adapter connected


oldschool
Oct 7, 2003, 01:24 PM
when the power adapter is connected, and my pb is charging i get a buzzing noise. Normal?

timbloom
Oct 7, 2003, 04:02 PM
I have never heard a powerbook buzz when an adapter was plugged into it, unless it was just the cooling fan. I would suggest you take it into a local apple specialist or call applecare if your machine is still in warranty. Just to be safe.

tjwett
Oct 7, 2003, 05:24 PM
Hope you read this. I am a Mac tech and the only time I see this happen is when the Power Supply is faulty. Unfortunately it seems to happen a little too often. There has been a handful of bad power supply batches released from Apple over the past few years. Stop using it right away and bring it into an Apple Store to have it checked. You can cause serious damage to your machine if you continue to use a bad one. Good luck.

oldschool
Oct 7, 2003, 05:38 PM
Originally posted by tjwett
Hope you read this. I am a Mac tech and the only time I see this happen is when the Power Supply is faulty. Unfortunately it seems to happen a little too often. There has been a handful of bad power supply batches released from Apple over the past few years. Stop using it right away and bring it into an Apple Store to have it checked. You can cause serious damage to your machine if you continue to use a bad one. Good luck.

Thank You very much. Sadly, it seems that i've used it already for a week. If my machine seems fine, do you think this is a cause for concern?

Gokhan
Oct 8, 2003, 07:41 AM
i had this problem with my g4 pb power adapter too !!!!
try taking out the battery and letting it sit on a non - static surfice and put it back this should cure it.

With mine i ordered a new one when it done this buzzing noise like tunning in a radio and when i tested the old one on a single socket not in any adapters e.g 4 way it was fine so see how it goes after doing the above before ordering a new one like me and getting stuck with something you don't need !!!!!!!!!!!!!!!!!!!!!!!!!!!!

oldschool
Oct 8, 2003, 12:39 PM
Apple is sending me a new one....as long as i send back the old one so its all good.

They tried a couple of trouble shooting steps like that with me over the phone but nothing helped.