PDA

View Full Version : My wireless internet keeps going out on my powerbook G4...




Mr.Macintosh
Jan 5, 2008, 07:57 PM
So I got a PowerBook G4(1.5 GHz, 512 MB RAM, a superdrive, and an airport card) for Christmas. :apple: :D :apple: :D:apple:
Before I opened it as a present, my cousin did a clean install of Leopard.
My wireless internet goes out every time I try to go to a new page or even refresh it. It's extremely annoying. In order to get it back on, I have to turn my airport card off, and then on again.
I was thinking it was my airport card, but then the other day, I went out of town to a friends house. My internet didnt go out once. I just got back today, and it keeps going out.
My home internet is locked with a password, but my friends internet wasn't.
However, I previously had a PC laptop and the internet was fine, my cousin has a MacBook Pro, and my brother just got a MacBook. All of them connect to the internet wirelessly and they don't have any problem with their internet.
I don't know what to do.
Thanks for any help



OrangeSVTguy
Jan 5, 2008, 08:37 PM
i had the same problem with my ibook but then i went into my router and changed it to mixed b/g as i had it set for g only for better performace for my xp laptop. i just changed it back to mixed and works great now. either that or change the channel on the router as you are probably getting interference.

CJRhoades
Jan 6, 2008, 09:38 PM
What type of pass is it? WEP? WPA Personal? Sounds like maybe the best thing to do is to just disable your WiFi security.

Mr.Macintosh
Jan 7, 2008, 01:23 AM
What type of pass is it? WEP? WPA Personal? Sounds like maybe the best thing to do is to just disable your WiFi security.
It's WEP. I would disable it, but my neighbors like to steal my internet :mad:

OrangeSVTguy
Jan 7, 2008, 01:35 AM
you can disable it but then you can also set up mac filtering only allowing mac address' on the list to gain access to your network. i'd try disabling your wifi first to troubleshoot your problem first like CJR mentioned. just find and pinpoint what the problem is. nothing like trial and error...

CJRhoades
Jan 7, 2008, 06:44 AM
Well, I think if it works when your security is turned off, you should probably just leave it off. Think about it, anybody who really wants to steal your internet is just going to hack into it. WEP security is VERY easy to get into. There are simple programs on the internet that will do it for you. I, personally could hack it in 3 mins without the program:D so don't worry about people stealing your internet. Chances are, somebody already is or has.

OrangeSVTguy
Jan 7, 2008, 09:35 AM
yeah just think about it the last time your internet went out... good thing your good ol' neighbor's wireless network was there when you needed it :p

btw: nice cousin you have to buy you a computer. also you ever think leopard to be the culprit?

yg17
Jan 7, 2008, 09:57 AM
WEP is almost as useless as MAC filtering. Does the router support WPA? If not, I'd buy one that does. And the suggestion to completely turn off security is even worse. And I'm not concerned so much with people using your internet connection, I'm talking about encryption. With MAC filtering and no security, everything you send (except for secure protocols like https and SSH and such) is UNENCRYPTED for anyone with the right equipment to sniff out and see. Your user ID and password you use to login to non-https sites like MacRumors? Anyone can get it. Your IM conversations? Anyone can get it. Your e-mail (depending on your provider, some are secure)? Anyone can get it. WEP makes things slightly better, but it's still extremely easy to crack. It's still unsecure enough for me to consider it utterly useless. And if you think MAC filtering is going to stop someone, you're dead wrong. It would take someone who either knows what they're doing, or knows how to use Google about 2 minutes to sniff out one of the valid MACs on your network and spoof it. WPA has yet to be cracked, and possibly never will be. I'd recommend using WPA (or better yet, WPA2, but WPA is still an excellent, secure option), or using no wireless at all. The only way to crack WPA is brute-force, so that's why you choose a good, secure password for your network. And with WPA, you don't even need to bother with MAC filtering (which is a pain in the arse if you have multiple computers and need to keep track of MACs)


Now to get back to the topic (sorry, but I just have to give a little lecture anytime I see someone using WEP, MAC filtering, or nothing at all).....my PowerBook is doing the exact same thing as yours unless I'm a few feet away from the router. My brother's MacBook holds a strong signal all throughout the house. I have no idea what's wrong, but it makes me think it's not the router. I'm probably going to drop it off at our authorized Apple repair center here on campus in the next week or two and let them take a look and see what's up with it. I posted here before and someone said it's the aluminum design of the PowerBooks that blocks wireless signals, but it never did this before, and Apple wouldn't be dumb enough to design a laptop that blocks wireless signals (that's why the antennas are on the outside, along the screen. That's what those rubbery, plasticy things are)

togermano
Jan 7, 2008, 01:44 PM
Sounds like to me that there must be magnets around the wireless card therefore its creating a magnetism atmosphere in which there wireless signals can't transmit. I bet its ur speakers.... I suggest you open up your powerbook and pull thoes speakers out

Mr.Macintosh
Jan 7, 2008, 06:57 PM
Thank you for all of your responses.
We are going to install a brand new router tomorrow.
I'm going to see how that turns out before I do anything.
So I'll let you all know how it goes.

Canerican
Jan 7, 2008, 07:12 PM
Make sure that you research routers before you buy. Many routers are spotty at best. Do not just buy the most expensive one, or get caught up by draft-N.

Mr.Macintosh
Jan 13, 2008, 03:25 AM
Well, we installed the new router.
At first, before we secured it, my internet was beastly.
Right after we secured it, it began doing the same thing.
I'm going to try and convince my family to take off the security,
or just go to the nearest Apple store and see if they can help me out,
because this is b.s.
I don't even enjoy going on my powerbook.

Reflow
Jan 13, 2008, 09:31 AM
Here’s a simple troubleshooting tip. Have you tried to take it to Starbucks or somewhere else that has free Internet just to make sure the wireless card is not bad...

darwinian
Jan 13, 2008, 09:52 AM
This is a known issue (as far as the user base is concerned; not sure if Apple has officially acknowledged our annoyance) with wireless using certain security and MacBook Pros on Leopard. This is the first I've read of PowerBooks having this problem, but I presume that the problem is Leopard. For some more information, next time the internet seems to cut out, go to your Console.app in Applications > Utilities and go down to the system log and check out the messages that get spit out regarding wireless. This will also help a support person tell if it is possibly hardware related or software.

Mr.Macintosh
Jan 13, 2008, 05:09 PM
To Reflow, I went to my friends house about 2 weeks back and I was there for a few days. My internet didn't go out one time. The only difference between his wireless internet and my wireless internet is that his is unsecured, and mine has a WEP code securing it.

And to darwinian, thank you for the suggestion. I tried it right away and this is what I got: 1/13/08 4:55:16 PM [0x0-0x9009].com.apple.systemuiserver[85] WirelessAP_GetStatus read error: Connection refused
:confused:

Reflow
Jan 13, 2008, 07:01 PM
To Reflow, I went to my friends house about 2 weeks back and I was there for a few days. My internet didn't go out one time. The only difference between his wireless internet and my wireless internet is that his is unsecured, and mine has a WEP code securing it.

And to darwinian, thank you for the suggestion. I tried it right away and this is what I got: 1/13/08 4:55:16 PM [0x0-0x9009].com.apple.systemuiserver[85] WirelessAP_GetStatus read error: Connection refused
:confused:

My suggestion would be get rid of WEP and use WPA or WPA2. Good luck.....

jvette
Jan 13, 2008, 07:20 PM
Just a thought here but who knows, do you have any type of wireless item that is turned on other than the computer. Like a wireless game chair or adapter on a game system. If there is something that is broadcasting a signal all the time or part of the time on the same frequency as the laptop card it will make the computer drop the connection.

Mr.Macintosh
Jan 13, 2008, 10:24 PM
Just a thought here but who knows, do you have any type of wireless item that is turned on other than the computer. Like a wireless game chair or adapter on a game system. If there is something that is broadcasting a signal all the time or part of the time on the same frequency as the laptop card it will make the computer drop the connection.
Nope. Don't have anything like that.

Mr.Macintosh
Jan 18, 2008, 03:27 PM
Ok. Well I finally got around to switching the security from a WEP to a WPA type security. My internet is noticeably slower than when it worked on the WEP. But whatever; At least it works.