PDA

View Full Version : Networking with XP


BiPolar
Oct 9, 2003, 07:10 PM
I'm sure that this has been answered before, but I am dying to network my XP Pro and OS X machines. On my mac, i've enabled windows login, sharing, set my workgroup name to "workgroup" on my PC, but I can't get it to work. My Mac can see my PC but not log in to it, but my PC can't even see my Mac. In fact, sometimes it says I don't have permission to access the workgroup (which is very odd, for it is MY NETWORK, DARNIT!) Can someone help me out?

cb911
Oct 10, 2003, 03:27 AM
i've just networked my PC (XP... not sure if it's Pro or Home) and my Mac (OS 10.2.8). i'm not exactly sure what i did to do it, but i think it was something with windows sharing... i had a bit of help with it. ;)

now i can get files from my PC via my Mac. i go cmd+k to connect to server, then select my PC from the list, not the workgroup, it's just shown as an '*'. then i log in a guest and can copy files.

to get to my Mac from PC, i just set up a new account, but now i can only get to the Public folder of that account. but i works for what i want to do.

i've looked into doing it properly... but it's a hell of a process. my advice would be to just become friends with a networking person. :D

VegetaPunk
Oct 10, 2003, 11:25 PM
You just have to make a new user profile, and then under your hard drive properties click the sharing tab then click on the add group (or something) button add your profile to it and give yourself all of the permissions...

on the mac side just (when this is done) in the finder click on the go menu item then select connect to server, or you could just hit Apple+K... then it will bring up your PC box and you can enter your Log & pass you just made....

mmmdreg
Oct 10, 2003, 11:34 PM
smb enjoyed screwing around with me so I just ftp to the mac from the PC. Works.

CrackedButter
Oct 11, 2003, 08:10 AM
When you get the SMB/CIFS box you shouldn't enter a password, instead just click enter then it will ask you to mount a share, which is whatever you have shared under windows.

I connect my iBook and XP machine up all the time and if i get an error its because of windows and not the mac.

Normally i click on "go" from the finder menu, then i connect to server, wait for it to load and find the XP machine then click on the"MSHOME" icon to find the PC

The name of, my XP machine is called "angela" i click connect and i get the SMB/CIFS Filesystem authentication box.

On that i have the Workgroup/Domain as MSHOME then username as CB (me on the mac) and the password is blank.

Click "OK" and it should then ask you which share to mount.

If you type a password you will get an error, i always did, something called "error code 36".

If this doesn't work then i don't know, this is still newbie for me but it works so i havn't found out other solutions!

yamabushi
Oct 11, 2003, 11:24 AM
I have all kinds of problems with networking in Windows. It works sometimes, with some versions, if the settings are just right and you aren't running any software that might interfere with it. Basically Windows prefers to find other computers using NetBeui which is a very bad way of connecting. NT and 2000 are known to be more reliable at networking than 98 and ME(ME was really bad). XP Pro is supposed to be slightly better than XP Home for networking.

If you want to find another computer and it isn't showing up in Windows, sometimes you can try to manually connect to it. One way is to use a window with a path bar - XP likes to hide these so it depends upon your settings. I think you can still use Internet Explorer if all else fails. In the path where it has a drive letter and directory or web address clear what is there and then type // and then the name of the computer you wish to connect to or it's IP address. Sometimes this works, sometimes not.

Another more powerful way is to use a DOS Window since you can do things such as ping to make sure there are no basic connection problems and even mount another computer as a drive volume that will show up in Explorer.