PDA

View Full Version : Leopard's Slowing down my G5, help me locate the cause




jihad the movie
Jan 11, 2008, 07:03 PM
I have a Dual 1.8ghz G5, with 3GB of RAM and the ATi 9600 Pro (64mb). I recently upgraded to Leopard with an Archive and Install, but it appears that the Finder is awfully slow when it comes to displaying the contents of a folder in icon view. This was never a problem with 10.4.11, but it is a problem now. (and an annoying one too)

I highly doubt I "need" more RAM, as all of my applications seem to be working just as fast as before, only the Finder exhibits any sort of lag. The drive which my system is stored on only houses my applications and documents, so it's not over filled.

Would upgrading my videocard help me at all? If so, which card should I look at getting? (I have a budget of $200.)

As always, thanks in advance.



noodle654
Jan 11, 2008, 07:22 PM
I would have erased and install. That is what I have done with all 4 of the Macs in my house. Originally I had Archive and Install on my brothers MacBook, but we erased the drive and did a fresh install...much faster.

CWallace
Jan 11, 2008, 07:29 PM
I agree. It's probably legacy code from 10.4.11. A clean install will likely make things more snappy.

HDproducer
Jan 12, 2008, 11:21 AM
That graphics card should be fine for running the OS.

I have a G5 2x2.0 and had the same card but I upgraded the graphics card because Motion 3 uses the GPU. I got a big boost there, but no difference for any other apps. What apps are you running?

Cards for these old G5 are getting expensive. $200 may not get you much of a jump. The clean install suggestion is what I would do.

jihad the movie
Jan 12, 2008, 11:32 AM
I run Adobe CS, iTunes, Transmission, Safari and Adium. Like I said before, it is only the Finder which exhibits any sort of lag.

I think I'm going to go for the clean install when I get a little time. Thanks for all your help.

eRondeau
Jan 12, 2008, 11:40 AM
Don't panic, it's easy to fix. I was shocked at how slowly the Finder was finding on my brand-new clean-install 2.8GHz C2D.

Click on the little gear icon in any Finder window and then Show View Options. Un-check the Show Icon Preview box. Voila!

By default, Show Icon Preview is turned on in Leopard. It orders the Finder window to render a miniscule version of whatever file it's displaying, instead of a standard icon. Keep it turned off and it'll speed you up a lot. :apple: