PDA

View Full Version : Fixing Out-of-Order SMS Messages on iPhone 1.1.3




MacRumors
Jan 28, 2008, 12:22 PM
http://www.macrumors.com/images/macrumorsthreadlogo.gif (http://www.macrumors.com)

Informationweek documents (http://www.informationweek.com/blog/main/archives/2008/01/iphone_113_upda.html;jsessionid=VPZKONP0D431WQSNDLOSKHSCJUNN2JVN) a new issue that appeared under iPhone 1.1.3 which resulted in SMS messages being displayed in the wrong order for some users.

Apple has posted (http://docs.info.apple.com/article.html?artnum=307364) a support document which offers a possible solution.[quote][i]This can occur if the iPhone is not displaying the same date and time setting as the carrier network time.

Make sure iPhone is setup to receive the network time. Choose General > Date & Time and turn Set Automatically to ON. (Note that in some locations, network time may not be available and in some cases, you may not see this option)./q>

Article Link (http://www.macrumors.com/iphone/2008/01/28/fixing-out-of-order-sms-messages-on-iphone-1-1-3/)



naroola
Jan 28, 2008, 12:49 PM
This does not exactly fix the problem. The setting on my iPhone has been "Set Automatically" ever since I got the phone in October 2007, and I still have SMSs messages out of order. The messages receive fine, but once you exit the SMS program and return to it later on, the last few messages are out of order.

Drumjim85
Jan 28, 2008, 01:20 PM
Mine too has been on this setting from the get go.... This is not a fix....

jimedit1
Jan 28, 2008, 01:25 PM
This is NOT a new issue to 1.1.3... I have had this problem since 1.1.1.

benspratling
Jan 28, 2008, 01:31 PM
In some areas, AT&T's cell towers have the wrong time. For instance, in Auburn, Alabama, (where I bought my cell phone) which is in the Central time zone, the cell towers force everyone's cell phones to the Eastern time zone. As a result, in Auburn, nobody uses the carrier's time, since it's always wrong!

Anybody in AU, have they fixed this yet?

naroola
Jan 28, 2008, 01:34 PM
In some areas, AT&T's cell towers have the wrong time. For instance, in Auburn, Alabama, (where I bought my cell phone) which is in the Central time zone, the cell towers force everyone's cell phones to the Eastern time zone. As a result, in Auburn, nobody uses the carrier's time, since it's always wrong!

Well, I live well in the East coast, i.e. Manhattan. And this is still a problem here. This is an unacceptable fix from Apple.

craigverse
Jan 28, 2008, 01:37 PM
Every so often my phone will display the carrier time by as much as three hours off. :[

shane1598
Jan 28, 2008, 01:53 PM
This does not exactly fix the problem. The setting on my iPhone has been "Set Automatically" ever since I got the phone in October 2007, and I still have SMSs messages out of order. The messages receive fine, but once you exit the SMS program and return to it later on, the last few messages are out of order.

This actually was a fix for me. Was always on "set automatically" so I switched to manual cause I noticed that AT&T time was 3 min slower than directv time, but over night the iPhone time was three hours off? So I went back to set to automatically and it has sinced fixed it.

I recomend switching the setting back and forth a few times since most everyone is auto anyways. .

Mindflux
Jan 28, 2008, 02:01 PM
Mine has always been set to get the network time and I have out of order SMS'

FCA
Jan 28, 2008, 02:22 PM
still out of order, didn't help anything!

jjm3
Jan 28, 2008, 02:57 PM
I haven't noticed this behavior on my iPhone with any of the software versions... I've kept it automatically set to the "carrier time" in preferences ever since version 1.0, and even today in 1.1.3 the listing of SMS conversations on the SMS main screen jump around to stay in chronological order, newest on top.

Slightly off-topic, the only thing I'm really sad about in the 1.1.3 update is the fact that SMSs no longer make the iChat noise when you're looking at the main screen; the only do the "whoop" noise when you're on the actual conversation's screen. It used to tickle me to race back to the main summary screen before the "sending" progress bar finished, and hear the sound as the little grey text preview updated...

Monk Edsel
Jan 28, 2008, 05:27 PM
I haven't noticed this behavior on my iPhone with any of the software versions... I've kept it automatically set to the "carrier time" in preferences ever since version 1.0, and even today in 1.1.3 the listing of SMS conversations on the SMS main screen jump around to stay in chronological order, newest on top..

The newest message should always be on the bottom. They should never "jump around."

jjm3
Jan 28, 2008, 05:51 PM
The newest message should always be on the bottom. They should never "jump around."

Oops, maybe I misunderstood the problem being discussed... I was talking about the screen where you see each person's name you're having a conversation with... on that screen they conversations jump around, so that the one with the most recent SMS message is on top.

On the screens with the actual back-and-forth SMS messages in an individual "conversation," yeah, absolutely, I've only ever seen the messages in the order the came in, newest at the bottom, scrolling down like a reglar iChat window.

brooker
Jan 28, 2008, 06:23 PM
This can occur if the iPhone is not displaying the same date and time setting as the carrier network time.

Make sure iPhone is setup to receive the network time. Choose General > Date & Time and turn Set Automatically to ON. (Note that in some locations, network time may not be available and in some cases, you may not see this option).

Notice the inconsistent use of articles preceeding "iPhone"? Usually, they don't say "the iPhone".

I wonder if this was written in a hurry.

sdunlapa
Jan 28, 2008, 06:42 PM
What fixed it for me, was setting the clock on iPhone to Atomic time. Usually the received text is marked with Atomic time and your outgoing is marked with iPhones time.

evands
Jan 28, 2008, 07:05 PM
In some areas, AT&T's cell towers have the wrong time. For instance, in Auburn, Alabama, (where I bought my cell phone) which is in the Central time zone, the cell towers force everyone's cell phones to the Eastern time zone. As a result, in Auburn, nobody uses the carrier's time, since it's always wrong!

Anybody in AU, have they fixed this yet?
My buddy at AU had a $300 phone bill one month about 6 years ago for the same reason - he didn't have free roaming, and his phone kept jumping on the Georgia tower you're seeing.

My iPhone stayed on the right time zone last time I was in AU - but I may have just gotten lucky. I was just there for the weekend so didn't have a very long test period.

dsl4c
Jan 28, 2008, 07:07 PM
doesn't fix the problem with my phone, "set automatically" has been on since day one, and still have crazy out of order SMS messages.. only with the 1.1.3 firmware however..

chanderr
Jan 28, 2008, 07:09 PM
This is definitely not a fix!

kstefanick
Jan 28, 2008, 08:57 PM
This does not exactly fix the problem. The setting on my iPhone has been "Set Automatically" ever since I got the phone in October 2007, and I still have SMSs messages out of order. The messages receive fine, but once you exit the SMS program and return to it later on, the last few messages are out of order.

I second that. Maybe we should what another person that posted did. Turn that setting off for awhile then turn it back on? I know that some problems on cells phones and computers you have to play with a little bit to work the problem out. Anyway, FTL on the blog. Only one person on here has this worked for.

chadsteruw
Jan 28, 2008, 09:53 PM
What fixed it for me, was setting the clock on iPhone to Atomic time. Usually the received text is marked with Atomic time and your outgoing is marked with iPhones time.

this might be a stupid question but how do you set the phone to Atomic time?

sdunlapa
Jan 28, 2008, 10:06 PM
this might be a stupid question but how do you set the phone to Atomic time?

You can go here. http://time.gov. Then enter that time into your iPhone. Manually.

benspratling
Jan 29, 2008, 10:33 AM
My buddy at AU had a $300 phone bill one month about 6 years ago for the same reason - he didn't have free roaming, and his phone kept jumping on the Georgia tower you're seeing.

My iPhone stayed on the right time zone last time I was in AU - but I may have just gotten lucky. I was just there for the weekend so didn't have a very long test period.

War Eagle!
But sad for your buddy's bill.

shane1598
Jan 30, 2008, 09:22 AM
This actually was a fix for me. Was always on "set automatically" so I switched to manual cause I noticed that AT&T time was 3 min slower than directv time, but over night the iPhone time was three hours off? So I went back to set to automatically and it has sinced fixed it.

I recomend switching the setting back and forth a few times since most everyone is auto anyways. .

EDIT: scratch that, it didnt fix the problem :mad: