PDA

View Full Version : Powerbook Boot Failure Using Internal and External HD




Mac Lad
Jan 28, 2008, 04:01 PM
Hi Folks,

I have a 12" Powerbook G4 running 10.3.9 Panther. I am having problem booting my computer from a Firewire HD. I have done a search in the forum but cannot get a definite and/or successul solution. Forum moderators and my respected macrumor fellows, please feel free to direct me to a specific link if you find the questions redundant.

Recently, I have had the HD making terrible noise and several days ago, the computer cannot boot at all. When I pushed the power button, the screen shows a folder in the middle with a Mac face and switches to a question mark back and forth. However, it just gets stuck at that stage. I suspected that I have a HD problem and wanted to boot from my clone Firewire HD. Unfortunately, the computer will not boot with Firewire HD either.

I turned on my Firewire HD and connected it to the Powerbook (that is currently off). Then,

1. I pushed the power button the powerbook and pushed CMD-OPT-SHIFT-DELETE simultaneously. Result: the computer gets stuck at a grey screen with a folder and a Mac face in the middle.
2. I turned off the computer, and restarted it now holding down the T button. Result: I obtain a black screen with big yellow firewire symbol floating around, but the computer still won't boot.
3. I turned off the computer, and restarted it now holding OPT button. Result: I see a grey screen with two arrows, however, it there is no disk picture from which I can choose the boot disk.

Sometimes ago, I did verify that I can indeed boot from the Firewire HD, so I don't think the Firewire HD is the issue. I really think that my HD is busted and I need to replace it. But, the fact that I cannot boot from Firewire HD really gets me.

Please help... thank you and I really really really appreciate it.

the confused Lad



Mac Lad
Jan 29, 2008, 10:16 AM
another thing that I did:

4. Tried to boot using single user mode by pressing CMD + S at startup. I intended to run "fsck -yf" command at prompt. Result: I never obtained a black screen with a prompt. Instead, I got a folder with flashing Mac face and question mark.

I read another post that battery could be the source of the problem. Is that true? How would that affect computer boot? I'm still wondering how I can boot from external drive (Firewire). All my attempts failed so far.

Please help... I thank you very much.

Consultant
Jan 29, 2008, 10:53 AM
Well it can be good news or bad news.

One possibility is that the logic board has a problem, but that means your data is intact. And that might be the case if you cannot boot from either internal or external disk.

You should try to boot using the system dvd and see if you can repair disk. If you have the original disk that comes with your powerbook, you can try running system diagnostics.

Mac Lad
Jan 29, 2008, 02:30 PM
Thanks for your reply Consultant, I very much appreciate it!

Unfortunately, I do not have the original system DVD that came with my powerbook. Hurricane Katrina ate it (really).

Either way, I think I am going to replace my hard drive and see where to go from there. The fact that the HD was making loud noise made me believe that there's some mechanical problem there.

If that doesn't work... then I'll replace the logic board maybe?

Thanks again.

Mac Lad
Feb 1, 2008, 01:32 PM
And yet another attempt:

5. I booted my ailing Powerbook using Ubuntu Live CD. It ran fine!! So, this give me the suspicion that indeed my hard drive is dead. But logic board is OK.

I guess it's time to shop around in ebay. I'll post results and stuff so hopefully it can be useful to others.

The lad

Mac Lad
Mar 12, 2008, 02:32 PM
Just finished replacing the Hard drive today. Got it from ebay. Now the laptop ran fine!!! So the old hard drive just died....Thankfully I had that back up drive.

Folks.... back up your data. Never know when your HD is going to fail you.

The happy Lad

JMax1
Mar 12, 2008, 10:10 PM
I ran into a similar problem with what I think is my hard drive going dead. I just finished replacing it, and I'm pretty sure I did it right. I have connected my PBTi to my iMac and the new HD in the PB is there, and I can pretty much use it as an external hard drive. I don't really want to do this though. I have put an old OSX10.4 disk in from my neighbor (my iMac is running leopard) and started up my powerbook holding down C as it boots. It starts to boot from the CD but then hangs on the grey (light grey?) screen with the apple logo. But then it doesn't do anything after that.

It just sits there, mocking me.

Any ideas what the problem is? Could it be because the disk I'm using is from a Macbook Pro purchase? I wouldn't think that's the problem, so maybe another issue is out to sabotage my old PB friend.

Any help is appreciated!

JMax1
Mar 12, 2008, 10:16 PM
OK, now I get this on trying to startup from CD:

http://gallery.mac.com/jmaxson1/100019/photo1205378044803/web.jpg

and

http://gallery.mac.com/jmaxson1/100019/photo1205378076155/web.jpg


I especially like the second one where it says: "Panic: We are hanging here..."