PDA

View Full Version : PowerMac G5 won't start. What could be wrong?




groovy8
Jan 31, 2008, 12:58 PM
This Question may sound familiar, but I really need a detail answer..

Here's how my G5 acts. (2G Dual)

Pushing power button just gives me double click sound and power light above power button just flashes when I press it. No solid light. Nothing happens. No fan sound. Battery on logicboard seems fine. I checked it with voltage meter, which showed3.7 volts.

PMU reset (I bought it before 2004) doesn't solve the issue.
I removed rams and video card and tried to boot, nothing happened.
Checked power cable and power outlet, everything is fine except G5.

Nothing has been installed recently. I used the G5 yesterday and it was working fine. I shut it down for an hour and boot it up to work on my music, but it's been acting like this since. I'm so worried about contents and programs in this computer.

I know I have to take it to apple shop, but I really like to know what's is wrong with it. Logicboard? or just bad battery? I hope it's the battery or power supply..

Has anyone had this problem? What was the cause? If anyone has experienced the same issue, I would like to hear it.

Thanks.



Eidorian
Jan 31, 2008, 01:01 PM
What's the speed of your Power Mac G5?

Pushing power button just gives me double click sound and power light above power button just flashes when I press it. No solid light. Nothing happens. No fan sound. Battery on logicboard seems fine. I checked it with voltage meter, which showed3.7 volts.This sounds a lot like this...

http://www.xlr8yourmac.com/systems/G5_coolant_leaks.html#storytop

groovy8
Jan 31, 2008, 01:17 PM
What's the speed of your Power Mac G5?


Mine is G5 2G dual 1.5g ram, 160GB HD, bought it around 2003.

Eidorian
Jan 31, 2008, 01:19 PM
What's the speed of your Power Mac G5?


Mine is G5 2G dual 1.5g ram, 160GB HD, bought it around 2003.I had a Power Mac G5 2.7 GHz pop and smoke over one weekend. Afterward it had the same click and flashing light on power up with no results.

groovy8
Jan 31, 2008, 01:31 PM
I had a Power Mac G5 2.7 GHz pop and smoke over one weekend. Afterward it had the same click and flashing light on power up with no results.


Did you get it fixed? what was the damage? and what parts were replaced?
I hope yours was on warrenty.. too bad mine is not.


I'm really hoping it's not an cooling system related issue....I read it somewhere.. it's gonna cost a lot...

echoout
Jan 31, 2008, 01:50 PM
This happened to my Quad. Power supply for mine. Free of charge, only took them like 3 weeks.

groovy8
Jan 31, 2008, 01:58 PM
This happened to my Quad. Power supply for mine. Free of charge, only took them like 3 weeks.


Was your Quad acting like mine? I would love to have a power supply issue.. instead of coolant leaks....

tugger
Jan 31, 2008, 02:20 PM
Was your Quad acting like mine? I would love to have a power supply issue.. instead of coolant leaks....
Hopefully it's only the PSU. Apple charges over $1000 for a logic board replacement -- and more if either/both of the cpu's are fried.

Eidorian
Feb 2, 2008, 02:27 PM
Did you get it fixed? what was the damage? and what parts were replaced?
I hope yours was on warrenty.. too bad mine is not.


I'm really hoping it's not an cooling system related issue....I read it somewhere.. it's gonna cost a lot...Apparently the user never got AppleCare and we replaced it with a Mac Pro. Most people under AppleCare get a Mac Pro as a replacement since cooling components are back ordered or scarce.

You probably have a bad power supply but I'd open it up and look for coolant.