PDA

View Full Version : Mac wakes up on its own?




Tommie Montana
Feb 5, 2008, 11:27 AM
Hello all,

My alu iMac seems to be waking up sometimes (so not all the time) when I'm at work. I am 100% sure I set it to sleep, and everyone else in the house says they didn't touch it. My work schedule is always about the same, so it's strange that 2 weeks ago it was awake when I got home, and since then 2 times more.

I've checked the settings, to be sure it doesn't have a schedule to wake and sleep. Everything looks OK. No schedule whatsoever, except wake after power failure. I've disabled that now but I don't think we had any power failures recently because iStat Pro indicates an uptime of 20 days straight, which would be hard to do without power.

Now is there a way to check any logs about wake and sleep times? I'm sure there is a command for the terminal that does exactly this but I haven't found it yet. I ordered the Missing Manual to learn more about OSX but I would like to check this now because the order could take a while.

Thanks in advance,

Tommie



Consultant
Feb 5, 2008, 11:37 AM
Sometimes power surge will wake up a computer.

Hankster
Feb 5, 2008, 11:46 AM
Cat? Dog? Hamster?

Tommie Montana
Feb 6, 2008, 11:31 AM
No animals that could open my room, and even when it were anyone else, I would notice. But a power surge doesn't sound realistic, since this never happened before, and the iMac is attached to one of those plugs with a switch.

Nobody with a command that shows me the time of wake-up?

jellomizer
Feb 6, 2008, 12:53 PM
I would go with the Power Surge or Change. My Wifes alu iMac wakes up every time you turn on or off the fan that is on the same circut. And it is hooked up to a UPS. Could it be that someone turns on a light or an other device in your room or on the same breaker. Or hooked up to a simular circut as your heat or AC

veteq
Feb 6, 2008, 04:21 PM
I just got my MAC a week so I could be completely wrong.
I had the same problem with mine, in my case turned out to be the logitech wireless mouse that I was using. Once I connected the MAC mouse (terrible mouse) the problem disappeared.

If that doesn't work, turn off the blue tooth, might be caused by a cell phone scanning for a blue tooth device.

Hope it works

Veteq

stevegmu
Feb 6, 2008, 04:51 PM
I just got my MAC a week so I could be completely wrong.
I had the same problem with mine, in my case turned out to be the logitech wireless mouse that I was using. Once I connected the MAC mouse (terrible mouse) the problem disappeared.

If that doesn't work, turn off the blue tooth, might be caused by a cell phone scanning for a blue tooth device.

Hope it works

Veteq

Logitech's drivers do funny things with Macs. After I installed Logitech Control Center, 1 of my Macs frequently had trouble waking up, so I deleted the program, and installed SteerMouse- which works great.

BlakTornado
Feb 6, 2008, 05:03 PM
If your mouse runs out of power (assuming it's wireless) when you have your machine on sleep, that can sometimes wake it up. I know it happened to me when I turned my MX Revolution off just after setting my iMac to sleep - the damn thing woke up immediately which does no good for the internals.

Why not set your computer to sleep after 15 minutes of not using it, or just turn it off and save yourself some dollars off your electricity bill when you go out?

Tommie Montana
Feb 8, 2008, 11:48 AM
No electricity is being used in my room besides the iMac that's sleeping.

I use the mighty mouse (wired), so that's also not the issue here.

So maybe it has to do with something on the same circuit somewhere that magically wakes the iMac.

If I only could find out when it woke up then I could probably figure it out.

Guess I'll have to wait for this missing manual to look up a command to check the logs.

XianPalin
Feb 8, 2008, 02:00 PM
Applications folder -> Utilities folder -> "Console" application will show you logs.

One thing I noticed - any peripherals turning on and off seem to wake up my Mac mini from sleep. I have a printer attached, and put my Mac to sleep and then noticed I had left the printer on. I turned off the printer and that woke up the Mac. Same thing happens if I sleep my mac and then turn off my LCD - it wakes it back up. So maybe make sure there it's not getting some sort of signal over USB from something.

Jazhawk
Feb 8, 2008, 05:12 PM
Not sure if this is true with all macs but I have two in my house and it happens with both. If I am running a good sized app like Word, Photoshop or something that requires some memory, my computer won't sleep. Never had any problems with open browsers.

So I have to click the apple and force quit big apps.

Sleeps like a baby after that.

-Jaz

Tommie Montana
Feb 10, 2008, 04:21 AM
Ok thanks XianPalin. I found this in the logs:

Feb 4 05:21:26 tommies-imac kernel[0]: System Wake
Feb 4 05:53:42 tommies-imac kernel[0]: System Sleep
Feb 4 16:47:18 tommies-imac kernel[0]: System Wake
Feb 4 16:47:18 tommies-imac kernel[0]: USB caused wake event (EHCI)
Feb 4 22:17:48 tommies-imac kernel[0]: System Sleep
Feb 4 22:17:49 tommies-imac kernel[0]: System Wake
Feb 4 22:18:23 tommies-imac kernel[0]: System Sleep
Feb 5 05:23:08 tommies-imac kernel[0]: System Wake
Feb 5 05:53:02 tommies-imac kernel[0]: System Sleep
Feb 5 06:48:32 tommies-imac kernel[0]: System Wake
Feb 5 06:48:32 tommies-imac kernel[0]: USB caused wake event (EHCI)
Feb 5 23:22:30 tommies-imac kernel[0]: System Sleep
Feb 6 05:21:33 tommies-imac kernel[0]: System Wake
Feb 6 05:53:10 tommies-imac kernel[0]: System Sleep
Feb 6 16:48:34 tommies-imac kernel[0]: System Wake
Feb 6 16:48:34 tommies-imac kernel[0]: USB caused wake event (EHCI)

So that's me waking it up at 5:20 and setting it to sleep at 05:55 every day. I wake it up when I get home using the mighty mouse, so that's why it says USB caused wake event. Feb 5th at 6:48 is another USB caused system wake, when I was already at work. It's just the mouse and keyboard that are attached via USB, and nobody enters my room normally, so someone has to be lying here I think. My pet dog (or a fly or something like that) can't enter the room and then start typing on the keyboard, and any other explanation seems to not apply here.

XianPalin
Feb 10, 2008, 09:38 PM
No idea if all you have hooked up is the keyboard / mouse.

Try unhooking them and then putting your Mac to sleep with the remote (hold down the play button for several seconds) and see if it still wakes up. Maybe there's something weird with the mouse or keyboard.

Tommie Montana
Feb 11, 2008, 03:33 PM
Yeah that's the thing, I always put it to sleep with the remote or the power button. I wanted to link a script at wakeup that takes a photo through photobooth but I couldn't get it to work. Anyway, since I asked everyone here if they perhaps been on my iMac this hasn't happened anymore.

At least now I know I wasn't forgetting to put it to sleep. I'm not going to try unhooking the keyboard to see what happens because this has only happened about three, maybe four times at random days (and seemingly random hours).

I'm hoping a bit to find it awake again to go all Sherlock Holmesy: So, where were YOU at around 6:48AM???

cbiweb
Mar 11, 2008, 12:00 AM
Hi everyone,

I found this thread after Googling about this very problem. My Mac mini keeps waking up on its own, and it shouldn't be waking up until I wake it up myself (i.e., hitting the space bar).

I checked the Console and found this message:
"Mar 11 00:29:53 My-Name's-Computer mDNSResponder: NOTE: Wide-Area Service Discovery disabled to avoid crashing defective DNS relay 192.168.15.1."

Such messages occur once every 24 hours - sometimes 48 hours - and coincide with the Mac waking up on its own.

Any advice?

Thanks. :)

cbiweb
Mar 17, 2008, 11:49 AM
Anyone?

Queso
Mar 17, 2008, 11:56 AM
Mine suddenly started doing this at midnight every night. I got rid of it by enabling all the Energy Saver scheduling options, then disabling them again. Bit of a weird one, but easily fixed.

icapricorn
Jul 24, 2009, 03:19 PM
Peer Guardian turned out to be the source of my unwanted wake-ups. Now I just quit from Peer Guardian before I put the iMac to sleep. I put it back on when I come up again.