PDA

View Full Version : Mac OS X 10.5 Email Question...




mjstempf
Feb 5, 2008, 11:56 AM
All,

I have 10.5 Server installed and working (mostly...lol). The problem I am having is that the email that is sent from the server is marked as "spam" on the common free email servers (gmail, yahoo, hotmail, etc).

I was wondering if anyone knows how to get this changed. I have a web address (www.whatever.net), but my internet ip address changes, so I am using dyndns to resolve to my server (using their dns client). I have a mail exchange record (MX) with them...and I can get and send mail just fine...it just gets marked as "spam".

Any help would be GREATLY appreciated...we are starting up a small company and I would like to use Macs for everything.

Thanks again,

Michael



stukdog
Feb 5, 2008, 12:49 PM
The most common reason for this is the the Reverse DNS doesn't match the hostname of the computer. This is a bit hard to set up with a dynamic ip address, but DynDNS does offer some assistance for it. (And also a service to help with it.)

Reverse DNS Overview From DynDNS (https://www.dyndns.com/support/kb/reverse_dns.html)

thomasbosboom
Feb 5, 2008, 01:14 PM
Another easy solution would be to relay your mail through your isp's SMTP server. This should be transparent to your users and the receiver but mail coming from a well known ISP's SMTP server is generally better accepted.

mjstempf
Feb 5, 2008, 01:43 PM
Thank you both for your comments...I will get on this today and try them both out. I will post my results here incase anyone else had the same sort of issues.

Michael

mjstempf
Feb 5, 2008, 07:24 PM
Ok, so I subscribed to "mailhop outbound" from dyndns (after emailing their support - that is what they said I needed to do.

Then I went into the Mac Server Admin...mail...settings....general....and put a check box next to "relay outgoing mail through host: outbound.mailhop.org" then clicked on "authenticate to relay with user name: xxxxxxxx password: xxxxxx"

Then I went to the advanced tab and enabled "Login" and "PLAIN" under SMTP (their directions for other Mail servers made it sound like that had to happen".

Now when I send an email address I get the following error (in logs...SMTP):

macserver postfix/smtp (number): warning: SASL authentication failure: No worthy mechs found.

What am I doing wrong?

joeconvert
Feb 6, 2008, 12:38 PM
Ok, so I subscribed to "mailhop outbound" from dyndns (after emailing their support - that is what they said I needed to do.

Then I went into the Mac Server Admin...mail...settings....general....and put a check box next to "relay outgoing mail through host: outbound.mailhop.org" then clicked on "authenticate to relay with user name: xxxxxxxx password: xxxxxx"

Then I went to the advanced tab and enabled "Login" and "PLAIN" under SMTP (their directions for other Mail servers made it sound like that had to happen".

Now when I send an email address I get the following error (in logs...SMTP):

macserver postfix/smtp (number): warning: SASL authentication failure: No worthy mechs found.

What am I doing wrong?

Hi there,
I don't have Server running, but I have been fighting postfix for a couple weeks configuring it to relay to my company's excahgne server for outbound ical invite purposes.

The issue you are describing is due to smtpd not synching with the server on a authentication protocol for the user/password. Try forcing the authentication mechanism in the smtpd.conf file.