PDA

View Full Version : Problem booting from CD, Flashing Question mark...


ScottDodson
Oct 22, 2003, 09:01 PM
Ok guys...right after i post on another thread on how I never have problems with my quicksilver...I messed up my streak of good fortune. I'll lay down what is going on:

I start my computer to get to the flashing question mark thing. But it's not over a folder, it's over a floppy disk. I believe this has happened because for some reason I deleted some os 9 system stuff on my computer, and accidentally selected 9 as my startup disk (don't ask...I don't know what the heck I was thinking). So now that it got restarted I'm stuck.....I've tried everything at the apple support page (holding X, holding option, resetting pram, and booting from disc). Anyone have any other ideas?? I'm open to anything. I know it's not hardware, so I ruled that out....I just want to boot back to my os x install disk :(

jamall
Oct 23, 2003, 11:58 PM
It sounds strange that you can't boot a cd with the c key held down. Have you tried an OS 9 cd? This might help, I pulled this text from a website somewhere a while ago, can't remember where:

Boot into Open Firmware (OF) by holding down the Command+Option+O+F keys during startup.

Type "printenv" at the prompt look for the boot-device setting. Write this down. Be accurate, the command line is unforgiving.

Type the following, assuming "mac-io/ata-4@1f000/@0:2,\\:tbxi" is your current setting:

setenv boot-device mac-io/ata-4@1f000/@0:2,\System\Library\CoreServices\BootX

then hit return. The only thing I changed was the "\\:tbxi" at the end, everything else stays the same. Also note that these are backslashes, not forward slashes!

Type "mac-boot"

Rejoice, because you're booting into X. Hopefully everyone gets to this step.

Now GO TO THE STARTUP DISK PREF PANE AND SET YOUR STARTUP DISK. You'll notice that it is still set to the OS 9 System Folder. That's because the GUI isn't designed to understand how we've tricked it. Just set the startup disk to your X disk. If you typed "nvram -p" in the Terminal before/after setting the startup disk, you'd see that it removes the \System\Lib... stuff and replaces it with \\:tbxi.

Hope this helps