PDA

View Full Version : iBook on the fritz? Please help.




ineptuoso
Feb 11, 2008, 12:22 PM
I've been trying to help my girlfriend fix her iBook G4. Her laptop is running terribly slow. She uses this computer for iTunes/iPod and running Safari and Word...not much else. Not sure why she would be having any problems. Hardrive space isn't a problem, as there is about 10G available.

The computer boots VERY slow...it takes at least 5 minutes. Once running, launching any application takes much longer than it should. Surfing the net also is very spotty. A page will load, then for no reason, the spinning beach ball (SBB) pops up and freezes the computer for 30 seconds to a minute. This happens the entire time online for any page...even after the page is fully loaded the computer continues to have the SBB appear every few minutes. This issue is not isolated to Safari...it seems the entire OS is lagging horribly. I tried running Disk Utility, which couldn't even finish. After spending 10+ minutes with the progress bar not moving, I gave up.

Her airport card also seems to have difficulty holding a connection. Her roommate has the same computer and has no problem picking up a signal anywhere in the house, while my girlfriend's computer can only pick up a signal in a specific spot on the coffee table. It's the only spot in the entire house where she can get a connection.

Another weird issue I noticed last night, next to the trash can, a finder icon appeared...it's smaller than the other icons on the dock and when I mouse over it the name "Macintosh HD" appears. I can't pull it from the dock, open it, or do anything with it. It just sits there. What's up with this?

I'm going to do a clean erase/install, but does this sound like a hardware failure? Please advise. Any input to resolving this would be appreciated, and could possibly make me look pretty cool in front of my girlfriend. Errr...on second thought, maybe it won't...but it would still be appreciated!

Thanks!
- k



Reflow
Feb 11, 2008, 12:41 PM
I suggest that a reinstall/format the drive would be the best thing to do. Also delete any old programs she doesn't use to free up some HDD space.

Quint
Feb 11, 2008, 01:27 PM
This doesn't sound like a hardware problem, but doing a clean install, while most likely will fix the problem, is a pretty drastic step. You can start by doing a safe boot - start up holding down the shift key until the spinning sprocket appears. It may take considerably longer than usual to start up. Once it boots, and you have logged in, see if the problems are still present. (You won't be able to connect wirelessly during a shift-boot.) See if you can run Disk Utility - Repair Disk. If the problems are still there, boot from the install Disc (Insert Disc and restart holding down C key. From there, you can open the Utilities menu bar item and run disc Utility. If none of these things find any problems, and System Profiler reports that the memory is OK, go ahead and reinstall the system software.