PDA

View Full Version : Panther Eats External Drives on Restart?


Makosuke
Oct 24, 2003, 02:49 PM
My copy hasn't arrived yet, but a couple of reports about problems with external drives over at MacInTouch (http://macintouch.com) are making me nervous, particularly considering that my initial install will probably be on an external FW drive.

The gist of the reports are that on a manual reboot 10.3 will (or might) render an attached drive completely unreadable. That's not a forced reboot, just selecting "restart" from the menu with an external drive mounted via Firewire, whether it's the boot drive or not.

There is one report from an apparent end user, and another from a guy who says the problems existed on and off throughout the development cycle. They don't give a lot of detail, but two is more than zero, and unnerving.

Both of the two reports involve drives in a FW800 case, so I'm also wondering if it's limited to FW800 connections, or if FW400 and/or USB2 are also succeptable.

Anybody had something like this happen, or is it more limited than it sounds?

tati
Oct 24, 2003, 03:08 PM
if it helps, i've been running 10.3 for the last month (ADC seeds) and have had them installed on both my internal and external drive without any problems. due to some of the problems i have been having with panther (corrupted preferences that came over from jaguar), i have also been regularly booting back and forth between the two, the firewire always being plugged-in.

again, this is my experience. :)

lok
Oct 24, 2003, 08:29 PM
My Panther installation ate my firewire drive...
I did a erase & install...
and my backup drive is now gone.
All my data are gone..

Anyone know a fix to get my data back?

please help !!

SPiX
Oct 25, 2003, 09:50 AM
Makosuke,
unfortunatly I can confirm this, my 180 GB HD firewire 400/800 USB2 is not readable anymore after installing Panther... long optimization... restart and... BOOM! It's gone.
reading some forum and mailing lists it seems that this happens only to BIG firewire external HD.
Someone said this has something to do with journaling.

:(

good luck!

P.S. Lok, you're a real genius!

Jack White
Oct 25, 2003, 09:53 AM
very worried about my 160gb fw hd now!

dcCma
Oct 25, 2003, 10:13 AM
Upon completing my Panther upgrade yesterday - noticed my partitioned firewire drive was gone - vanished.. will not mount . . .. searching for answers still.. . . not ready to re-format .. got hope :)
~c

Makosuke
Oct 25, 2003, 09:09 PM
Ok, judging by the responses here and several more reports (http://www.macintouch.com/panreader03.html) over at MacInTouch, this is a potentially major issue even if it doesn't effect everyone.

There is also some discussion over at the Apple forums (link (http://discussions.info.apple.com/WebX?50@137.JUdbav0xhzy.16@.599b4a59), but I'm not sure if direct links to Apple's forums work...)

Nobody has stated the exact set of conditions that precipitate the failures yet, and there seem to be a number of potential ok and not ok situations. People are describing FW400 and 800, both with and without USB2, as being problems, and big drives seem more prone but not guaranteed to fail and perhaps not the only possible target. At least one person linked the failure to their iSight, too.

The only consistant thing seems to be restarting with the drive plugged in.

It'd be really, really useful to pin down a set of risk factors if anybody is privleged to this information or we can piece it together from reports and/or experimentation.

I know I'm going to be being VERY careful with my external drives, and this sort of shakes my faith in my current drive allocation plans...

itsbetteronamac
Oct 25, 2003, 11:44 PM
Originally posted by lok
My Panther installation ate my firewire drive...
I did a erase & install...
and my backup drive is now gone.
All my data are gone..

Anyone know a fix to get my data back?

please help !!
Sorry About what happend to you and the others who got their Ext. drives "eaten". I don't believe there is away to get the data back if it won't mount, or even if it will mount.

The only thing I can think of would be to take the drive to someone like Drive Savers http://www.drivesavers.com/. They have been recomened by lots of people and tech shows. And have been around for a long time. They have also worked with many prestigious clients, but you will find all about this on the web site. Disc Doctors, http://www.diskdoctors.com/ is another company, but I don't know much about them.

Again sorry about what happend to you

nacl99
Oct 26, 2003, 12:37 AM
i wouldn't go hiring some expensive hack to look at your HD.

I doubt your drive is fried, the data is still on there, it probably hasn't been over written?

If thats the case just find one of those programs that searches for deleted data.

I used to know of some for Windoz but I don't know any Mac ones.

But yeah don't waste your money on those people.

Makosuke
Oct 26, 2003, 12:55 AM
For those who've lost data (to this or similar issues), I recommend giving DataRescue a try (http://www.prosoftengineering.com/).

I admittedly haven't used it in a long time (haven't had reason to), but several years back (version 2.1) I had a hard drive horribly corrupted by Norton Utilities. Diskwarrior, Disk Utility, and Norton all failed to do anything to help, but Data Rescue saved everything on the drive.

It's not designed to fix things, just to get data off a severely toasted drive when all else fails, but at least way back when, it did that when nothing else could.

If you don't want to take my word for it, check out the comments at VersionTracker (http://www.versiontracker.com/dyn/moreinfo/macosx/1133)

dcCma
Oct 26, 2003, 01:01 AM
i've located, in my user/library/caches/dektop area, a dplImageCache file for each and every folder that was hosed from my drive(s)->(2 partitions on 1 drive) -
the original modification dates are all intact .. i'm thinking these bad boys are still sitting on the grill .. . am i reaching??

does anyone out there see an update or fix for this mess in their crystal apple?

just lettin' it out .. .. whewwww


thnx_c

http://homepage.mac.com/accessv

gotohamish
Oct 26, 2003, 02:38 AM
Originally posted by Jack White
very worried about my 160gb fw hd now!

Just unplug them when you do the install, no?:confused:

dcCma
Oct 26, 2003, 03:06 AM
Yes!! physically move the drive to another room, office or den!!
. .. if only my fedex shipment had been delayed . .. . i'da known then babay

Dreamail
Oct 26, 2003, 03:52 AM
Dont' know if it really works (haven't tried myself) but in the Apple forum one guy wrote that he was able to get his files back with Data Rescue X http://www.prosoftengineering.com/products/data_rescue.php.

For those desperate, maybe worth a try?

Jack White
Oct 26, 2003, 04:15 AM
Originally posted by gotohamish
Just unplug them when you do the install, no?:confused:
i did..just very worried about hooking it back up now!

Dreamail
Oct 26, 2003, 04:29 AM
Originally posted by gotohamish
Just unplug them when you do the install, no?:confused:

Sure, but what if the external drive is my startup drive?
Wouldn't really work without having it plugged in, no?

Lz0
Oct 26, 2003, 07:29 AM
Try this

unplug the effected drive

reinstall 10.2

plug in effected drive

and hope it works