PDA

View Full Version : Blue screen when installing drivers in bootcamp




bitty417
Feb 12, 2008, 08:02 AM
Well I finally got the drivers off of the MBA install DVD (http://forums.macrumors.com/showthread.php?t=430320). Just dumped them on to a USB stick. I installed XP Pro again using bootcamp assistant without a hitch. Rebooted into XP, put the USB stick in and ran the setup.exe off of it. XP blue screened when installing Broadcam drivers it appears.

Am I doing something wrong? Anyone experience similar issues?



bitty417
Feb 12, 2008, 02:02 PM
Ok, lemme try something else. Has anyone installed bootcamp/xp successfully? If so .. can you outline how you installed drivers?

macftw
Feb 19, 2008, 01:12 PM
Ok, lemme try something else. Has anyone installed bootcamp/xp successfully? If so .. can you outline how you installed drivers?

Well I came here looking for the answer to that same question! I'm getting blue screens on my Air as well. I'll post back here if I make progress.

AndyK
Feb 19, 2008, 01:20 PM
When XP loads for the first time, insert your leopard CD into your cd drive, it will auto run and install everything.

macftw
Feb 19, 2008, 01:33 PM
When XP loads for the first time, insert your leopard CD into your cd drive, it will auto run and install everything.

Have you done that successfully on an *Air*?

macftw
Feb 19, 2008, 01:36 PM
Bitty, I just got it to work. Here's what I think your problem might be. If you copy from the Leopard retail disk, you will get Bootcamp 2.0. However, that will bluescreen on an Air. You need Bootcamp 2.0.1 which comes on the disk with your Air.

I installed from an external CD/DVD drive. The retail Leopard DVD (2.0) bluescreened on setup, the CD that comes with the Air (2.0.1) worked fine.

ProPedderKustom
Feb 19, 2008, 01:43 PM
Have you done that successfully on an *Air*?

I had a similar problem when I tried to use a Leopard disc that did NOT come with my MBA. You MUST use the MBA Leopard install discs to put the drivers on XP or else it will blue screen at some point during the driver install. Once I used the MBA install disc to get the drivers, all was well.

Hope that helps!

dj2xl
Jul 21, 2008, 03:30 PM
The Broadcom driver install is what is causing Windows to blue screen. I copied the content of the Boot Camp disk (when you put in your Leopard disk in Windows) to a local folder; moved the BroadcomInstaller to a different location; and ran the BootCamp installer in the Apple folder. Everything installed without any problem.

ouida
Jul 30, 2008, 10:20 AM
The Broadcom driver install is what is causing Windows to blue screen. I copied the content of the Boot Camp disk (when you put in your Leopard disk in Windows) to a local folder; moved the BroadcomInstaller to a different location; and ran the BootCamp installer in the Apple folder. Everything installed without any problem.

It worked!!! Thanks so much for this tip. I was really frustrated after getting so many errors during this install (which was weird, since I've done this on a few other computers before this one).

MacR Novice
Aug 25, 2008, 07:23 AM
I, too, have been experiencing the blue screen within about 45 seconds of switching from OSX to Win XP. Like dj2xl, a friend suspected Broadcom/Bluetooth being the culprit. The default driver file is applebt.sys V2.0 (dated Oct-2007). However, there is a V2.1 driver (dated Apr-2008) at http://www.broadcom.com/products/bluetooth_update.php.

After installing the new driver, my Win XP environment crashed again this morning! :mad: After it rebooted, and before the blue screen appeared again, I quickly shutdown Windows [Note: Shutdown, not Restart nor revert to OSX].

After restarting in directly into Win XP, I waited for the inevitable to happen, but it didn't - no blue screen! I performed a search for the applebt.sys file to see if there were any other older versions lurking in some dark corner. The result showed four occurrences of the file; two V2.0 and two V2.1. I replaced the V2.0 files with the V2.1 file, then switched back to OSX in order to test the updated driver.

With OSX up and running, I restarted Win XP and didn't encounter any blue screen! :) My faith in using my Bluetooth devices in Win XP has been restored. :D

Martin.

MacR Novice
Sep 6, 2008, 03:40 PM
After restarting in directly into Win XP, I waited for the inevitable to happen, but it didn't - no blue screen!

I have to report that, despite what was written on 25-Aug-2008, I have been experiencing (six) more blue screens on my iMac. :confused:

Therefore, I should retract my words about Broadcom, as it may not have been a Bluetooth problem after all. Some additional investigation to-day has revealed it could have been the ATi driver. My Device Manager was showing ATI Radeon HD 2600 XT as my Display adapter. Apparently, it should show ATI Radeon HD 2600 PRO.

I have followed the instructions provided by StChuck (http://discussions.apple.com/message.jspa?messageID=7962175) and all seems OK (again). I would add that I believe his Step 8 should read "C:\ATI\SUPPORT\8-8_xp32_dd_ccc_wdm_enu_67975\Driver\XP_INF\CX_67975.inf"

Martin.