PDA

View Full Version : usb SD card reader & panther


optijaz
Oct 25, 2003, 05:49 PM
Is any one else having problems mounting a usb SD card from a reader?

I don't know why panther is not moutning this for me.

Any suggestions how to get around this?

Hoosier_1701
Oct 27, 2003, 04:20 PM
I don't have an SD card reader, but I do have a Smartmedia card reader that I'm having problems with. The reader seems to get power, and it shows up in the System Profiler, but inserted Smartmedia cards never mount on the desktop. I have posted this issue on a few boards, but so far I haven't had any responses.

Anyone else?

snickelfritz
Oct 27, 2003, 06:03 PM
I just plugged the Dazzle USB cardreader into one of the keyboard ports.
Works like a charm; mounted on the Desktop and opened the pix in iPhoto.

j33pd0g
Oct 27, 2003, 06:08 PM
My USB Kodak reader works fine. Ejecting the card used to make the green light go off. But not any more. No big deal I guess.

optijaz
Oct 27, 2003, 06:23 PM
Your right Hoosier_1701 the reader loads and is recognized by the system it's just the inserted card does not load.

I'm looking forward to the 10.3.1 update now.

snickelfritz
Oct 27, 2003, 09:05 PM
It may be something specific about the SM card or the device used to write the data on it; the SM card from my Olympus Camera works nicely, as does the memory stick from my Sony Camcorder.

Looking forward to 10.3.1

Hoosier_1701
Oct 27, 2003, 10:30 PM
The Smartmedia card is readable in the camera (Olympus 2020z), and readable in the card reader when connected to a Windows 2000 machine, so I'm guessing there is something in Panther. I'm pretty sure my card reader used to be listed on the iPhoto web page (http://www.apple.com/iphoto/compatibility/camera.html), but it isn't anymore. I wonder if support was left out of 10.3 for some reason. I'm hoping it gets back in for 10.3.1.

Superdrive
Oct 28, 2003, 12:03 AM
I have a VST Tri-Media reader and it only picks up the floppy drive. Hopefully 10.3.1 will pick it up.

Hoosier_1701
Oct 29, 2003, 09:39 AM
I was able to get my Sandisk Imagemate Smartmedia card reader (SDDR-55) working today, so I thought I'd post the details for anyone else having the same problem. Someone on another forum had posted something about a particular kext that supported his card reader under 10.2. It was OnUSBMassStorageClass.kext. I did an archive and install to Panther, so I checked my previous system folder. The above kext was in Previous System ->Previous System 1 -> System -> Library -> Extensions. The kext was not present in the Panther System -> Library -> Extensions folder. So, using "sudo cp" in terminal, I copied the kext from my previous system to the new one. After a reboot, I successfully downloaded pictures from the card reader.

I have not noticed any system instability so far, but there is always the chance this could cause a problem later. I do wonder why this kext was left out of Panther. (On a side note, my Panther package was missing disk 2, so it is possible this kext was included in one of the disk 2 packages. I still haven't received a disk 2 from Apple.)

Le Big Mac
Feb 23, 2004, 09:53 PM
Originally posted by Superdrive
I have a VST Tri-Media reader and it only picks up the floppy drive. Hopefully 10.3.1 will pick it up.

My SanDisk 8-in-1, (model 88) does not work under Panther. Boo.

stcanard
Feb 24, 2004, 11:03 AM
My Sandisk 3 in 1 works with no problems.

I've only ever tried SD Cards in it, though.

superbovine
Feb 24, 2004, 02:43 PM
Originally posted by snickelfritz
I just plugged the Dazzle USB cardreader into one of the keyboard ports.
Works like a charm; mounted on the Desktop and opened the pix in iPhoto.

yep my dazzle works great too.