PDA

View Full Version : MBA keyboard issues




off in the wood
Feb 13, 2008, 11:06 PM
So I've had my MBA for a little over a week and a half, and I like it a lot. However, just recently the F1 through F12 keys don't work anymore.

Well I shouldn't say they don't work, they do, but they do not do what they are supposed to do.

for instance, if I press F12 the widgets pop up. its supposed to increase the volume. all of the F keys are this way. Like they are all random.

Is this something that I amble to fix...in settings possibly?

Thanks for the help in advance



Fuzzbear
Feb 13, 2008, 11:15 PM
So I've had my MBA for a little over a week and a half, and I like it a lot. However, just recently the F1 through F12 keys don't work anymore.

Well I shouldn't say they don't work, they do, but they do not do what they are supposed to do.

for instance, if I press F12 the widgets pop up. its supposed to increase the volume. all of the F keys are this way. Like they are all random.

Is this something that I amble to fix...in settings possibly?

Thanks for the help in advance

what happens if you hit fn then F12?

steve31
Feb 14, 2008, 02:31 AM
I have had no problems yet with any of those keys.

snej
Feb 14, 2008, 04:30 AM
for instance, if I press F12 the widgets pop up. its supposed to increase the volume. all of the F keys are this way. Like they are all random.


Check System Preferences: Keyboard and Mouse, the Keyboard tab:
Is "Use all F1, F2 etc. keys as standard function keys" selected?
If it is, then the behavior of your keyboard is as expected.
Deselect that option to reenable the special features without pressing Fn

dahcheet
Feb 14, 2008, 07:06 AM
Check System Preferences: Keyboard and Mouse, the Keyboard tab:
Is "Use all F1, F2 etc. keys as standard function keys" selected?
If it is, then the behavior of your keyboard is as expected.
Deselect that option to reenable the special features without pressing Fn

If you do this and the F9-F12 keys still do the shortcuts for Expose (window move/change focus) and Dashboard (widgets) then go into the Keyboard Shortcuts menu also (in the Keyboard and Mouse settings in System Preferences) and scroll down. There should be section for Expose/Dashboard that allows you to turn off their F key shortcuts. Apple now has them mapped to specific Fn + F keys now anyway so there's no need for two keyboard shortcuts.

Hope that helps.

off in the wood
Feb 14, 2008, 12:41 PM
Unchecking the "F" box in keyboard and mouse settings worked. Thanks for everyone's help

except for you steve31

I have had no problems yet with any of those keys.

How was that supposed to help me???

FYI-Next time if someone has a question try focusing on a way to help them, rather than posting a response to add to your total posts