PDA

View Full Version : internet connection sharing


hugov
Oct 26, 2003, 03:51 PM
Internet connection sharing from a panther machine (g4 cube) to a jag 10.2.8 machine (12"powerbook) doesn't work at all. we have tried everything. soetimes it randomly works for about 15 minutes then stops again. does anyone know how to fix it?

it does the correct stuff with dhcp, the powerbook gets a valid ip, other types of network operations like file sharing and remote login still work. the powerbook has the correct ip for its 'gateway' also, but it still doesnt work.

cheers

MacRAND
Oct 26, 2003, 06:12 PM
Panther is loaded on both my G3 iBook and G4, so I can't duplicate your problem.

I seem to remember from some Panther Orientation (can't remember exact source) that for networking / sharing to really work WELL - BOTH machines must be PANTHER. :(
Note that Apple has a history of qualifying funtionality where things do really work, but maybe not "well" or all the time. OS X 10.0 is a good example, Apple said it only work on certain levels of machines, but many found that older computers with less horsepower run OS X reasonable well. Regardless, Apple needed to set the landmark stake, which let's us push the limit.

I hope I am wrong, because many older machines may be so challenged by architecture, speed, or Quartz capability, that many will be staying with Jaguar, like those stuck on 9.2.2.

Why should NON-Panther machines be prevented from networking effectively with Panther computers? :confused:

I have read that Panther is more PC network capable and that it lets Apple computers fit more neatly into a PC dominent network - and PC network compatibility is definately an Apple CORPORATE goal in order to open up sales (money) within mixed OS networks. :rolleyes:

You should check with an Apple Store genius or AppleCare if you still have access, unless an online Mac guru knows more. :cool:

hugov
Oct 28, 2003, 03:11 PM
It wouldn't surprise me if it only worked with other panther machines, but that would be BAD. like what microsoft do with each new version of windows.

Does anyone have any more suggestions, i NEED to ge this working, because i won't be installing panther on my powerbook for a few months yet (i have a lot of manually built unix tools that i am not sure if they will work on panther, and anyway they take ages to rebuild, so i don't want to unnecessarily break them just yet...)

MacRAND
Oct 28, 2003, 04:44 PM
Do you have a friend that you can work with who has Panther on a computer? Try setting up a network with them.

I'm not the person to tell you that your UNIX stuff will OR will not work on OS X or Panther specifically, but I hear it will. If it works in Jaguar, it should work in Panther.

BACKUP everything by burning DVD-R discs, or dump everything wholesale on an external hard drive.

Install PANTHER over what you have now on your laptop and see how it works. Try to do a regular install instead of a Clean Install first.

You can always trash the PANTHER system and re-install Jaguar. To reinstall a downgrade, I'd probably turn my iBook into a "T"ransfer "T"arget FireWire Drive by hooking it up to my G4 by FW cable, then I'd install Jaguar with the iBook as the "target drive" from my G4.

Just protect your DATA and UNIX stuff with backup.

What do you think? :confused:

StarmanDeluxe
Oct 28, 2003, 04:56 PM
It works fine between my Jag iBook and my Panther iMac, so it looks to be just your machine.

hugov
Oct 28, 2003, 08:36 PM
StarmanDeluxe, is that with one machine on dialup? or do you have a broadband connection?

Do you have a proper network, with switch etc, or like me are you using a cross-over cable (although i dont see how that would make any difference).

what have you got your network settings on? are you using DHCP or fixed IP addresses?

sam_c79
Nov 3, 2003, 09:04 AM
You're not the only one with this problem. There are quite a few posts on the Apple discussions forum:

http://discussions.info.apple.com/WebX?14@195.QONYa0kpiuZ.70@.599b4a6f

I had the same problem with an 800MHz iBook connected to the net via AirPort to a Netgear DGM824M wireless gateway (static IP from ISP with router using DHCP to distribute IP). I was sharing the connection to another 700MHz iBook via ethernet. All worked fine when both iBooks were running Jaguar. When Panther was installed on the 800MHz iBook (archive and install) Internet Sharing no longer worked. Tried messing with various settings but nothing's worked.

Just upgraded the other iBook to Panther. Will let you know if this fixes things.

sam_c79
Nov 4, 2003, 05:45 AM
Looks like running Panther on both machines fixed it. But I'm not sure if this works for everyone.