PDA

View Full Version : glu required




titaniumdecoy
Feb 19, 2008, 03:15 PM
Hi all,

I am trying to build the latest version of XMoto. I fixed the first two configuration problems by installing libjpeg and libpng. But now I get the following error:

$ ./configure
<snip>
checking for gluBuild2DMipmaps in -lGLU... no
configure: error: glu required

I did a search which came up with something called SDL, so I installed that too. But I am still getting the same error. Does anyone know what glu refers to?



yeroen
Feb 19, 2008, 03:23 PM
Hi all,

I am trying to build the latest version of XMoto. I fixed the first two configuration problems by installing libjpeg and libpng. But now I get the following error:

$ ./configure
<snip>
checking for gluBuild2DMipmaps in -lGLU... no
configure: error: glu required

I did a search which came up with something called SDL, so I installed that too. But I am still getting the same error. Does anyone know what glu refers to?

The clue here is the reference to gluBuild2DMipmaps. (A bit of google searching reveals that) This is part of glu, which is the OpenGL Utilities Library.

I'm not at my Mac right now, but on Linux/X11, the symbol gluBuild2DMipmaps is found in /usr/X11R6/lib/libGLU.so. Are you compiling this for X11 or for Aqua?

titaniumdecoy
Feb 19, 2008, 11:35 PM
I managed to fix the problem by appending --with-apple-opengl-framework to the ./configure command. Although now I have more problems to deal with. :(

titaniumdecoy
Feb 20, 2008, 02:08 AM
@yeroen: To answer your question, I am trying to compile for OS X, although clearly it is apparently using a number of X11 libraries.

I can't seem to figure out the problem here...

checking for library containing lua_pushboolean... no
configure: error: liblua5.1
./configure: line 7514: exit: liblua50: numeric argument required
./configure: line 7514: exit: liblua50: numeric argument required
Thanks for any suggestions.

Cromulent
Feb 20, 2008, 04:47 AM
@yeroen: To answer your question, I am trying to compile for OS X, although clearly it is apparently using a number of X11 libraries.

I can't seem to figure out the problem here...

checking for library containing lua_pushboolean... no
configure: error: liblua5.1
./configure: line 7514: exit: liblua50: numeric argument required
./configure: line 7514: exit: liblua50: numeric argument required
Thanks for any suggestions.

Lua is a scripting language. You need to compile and install it to get it to work (or the library at least).