PDA

View Full Version : MetaX troubles




jmccray
Feb 20, 2008, 06:08 AM
Hey guys. Just started having this problem. Trying to tag my movies in MetaX, and it won't even recognize the movie when I drag it over. It just started happeneing. I can't even go through the long way of opening it from File open. It's like it isn't there. I used Handbrake to encode. Please help!!!!



MikieMikie
Feb 20, 2008, 06:26 AM
Hey guys. Just started having this problem. Trying to tag my movies in MetaX, and it won't even recognize the movie when I drag it over. It just started happeneing. I can't even go through the long way of opening it from File open. It's like it isn't there. I used Handbrake to encode. Please help!!!!

Why not send the developer an email? It could be his bug.

jmccray
Feb 20, 2008, 07:33 AM
Why not send the developer an email? It could be his bug.I did. Just wanted to see if anyone else was having this problem.

OldSkoolNJ
Feb 20, 2008, 07:47 AM
I noticed that if th file extension is all Caps it wont recognize it. Make sure it is .mp4 and not .MP4. If not that then I dont know what.

Kevin :apple:

jmccray
Feb 20, 2008, 08:01 AM
I noticed that if th file extension is all Caps it wont recognize it. Make sure it is .mp4 and not .MP4. If not that then I dont know what.

Kevin :apple:It is actually .m4v. You think that is my issue? This has not been a problem until today.

spice weasel
Feb 20, 2008, 08:22 AM
It is actually .m4v. You think that is my issue? This has not been a problem until today.

It should tag .m4v files with no problem. It has always worked for me. What version of Handbrake are you using, 0.9.1 or the latest 0.9.2?

jmccray
Feb 20, 2008, 08:23 AM
It should tag .m4v files with no problem. It has always worked for me. What version of Handbrake are you using, 0.9.1 or the latest 0.9.2?The latest....0.9.2

spice weasel
Feb 20, 2008, 08:47 AM
The latest....0.9.2

Hrm. I just started re-encoding with 0.9.2 and haven't started tagging files yet. I hope this isn't a bug. How about renaming the files with an mp4 extension? Does that work?

NightStorm
Feb 20, 2008, 08:51 AM
Hrm. I just started re-encoding with 0.9.2 and haven't started tagging files yet. I hope this isn't a bug. How about renaming the files with an mp4 extension? Does that work?

No, I've been able to tag .9.2 files in MetaX. I have seen this problem occasionally before with previous versions of MetaX, but closing/reopening usually fixed it for me.

dynaflash
Feb 20, 2008, 09:12 AM
okay, so heres the deal with the new appleTV preset in HandBrake 0.9.2:

The files are 64 bit mpeg4's this is so that you can have an mpeg4 file over 4GB (32 bit mpeg4's cannot be over 4GB). This was a decision made right before release as we realized that with the extra 448kbps for the AC-3 surround track you could start hitting that 4GB barrier alot earlier than without. For example longer movies like LOTR would end up in the 4.5 GB area.

We have already contacted Kerstetter (the developer of MetaX and also a handbrake fanatic) and he has told us he can fix metaX to work just fine with it. In the past he has always been very fast with is updates if we request them so expect to see an update to MetaX very soon.

A note on the 64 bit option: Go to preferences -> advanced in HandBrake and there is a checkbox there to show the 64 bit checkbox in the main window. It is hidden in the main window be default as in the past it has been a very niche feature that also if incompatible with almost all devices except now the atv2. Anyway, check that box and you will see a new checkbox appear in the main window right by the Ipod Atom checkbox. You can now choose to turn that off if you wish to use MetaX for movies under 4GB until MetaX is updated.

I admit, I should have made the box visible all of the time now as its likely to be used alot more now. Thats what you get when you add new features right before release.

Hope this helps.

spice weasel
Feb 20, 2008, 09:20 AM
Thanks dynaflash. And thanks for the great work on Handbrake, especially 0.9.2. We Apple TV owners are now VERY happy!

HobeSoundDarryl
Feb 20, 2008, 10:11 AM
Did you upgrade to the latest (leopard required) MetaX? I did and suddenly couldn't get new Handbrake .9.2 files to work. I tried various things like changing the suffix from .mp4 to .m4v, etc. with no luck.

Then, I deleted the new version and switched back to the older (MetaX) version (for Tiger, but I'm running it on Leopard). No problem tagging the same files (as always before).

I believe the newest version of MetaX may have some issue with the new Handbrake renders.

jmccray
Feb 20, 2008, 10:22 AM
Did you upgrade to the latest (leopard required) MetaX? I did and suddenly couldn't get new Handbrake .9.2 files to work. I tried various things like changing the suffix from .mp4 to .m4v, etc. with no luck.

Then, I deleted the new version and switched back to the older (MetaX) version (for Tiger, but I'm running it on Leopard). No problem tagging the same files (as always before).

I believe the newest version of MetaX may have some issue with the new Handbrake renders.How large were your files?

HobeSoundDarryl
Feb 20, 2008, 11:00 AM
One was 1.91Gb. Another 2.47Gb. A third was just 106.9Mb.

Also, while the suffix .mp4 or .m4v will go into iTunes just fine, it appears only the .m4v suffixed files will show up in :apple:TV Take 2. After I tagged all 3, the one that was 1.91Gb was suffixed as .mp4. All 3 went into iTunes just fine, and everything looked normal.

However, only the 2 ending with .m4v were showing in my :apple:TV movies list. I switched to "trailers", then back to "My Movies", etc, but none of that made the .mp4 suffixed file show. Then, I went back over to the Mac, changed the suffix to .m4v, deleted the file out of iTunes, and dropped the newly renamed file in. Everything looked normal again in iTunes. When I checked the :apple:TV list, the missing movie now shows.

I have many movies rendered by previous versions of Handbrake that suffix with .mp4. They all show, so this looks like something newly connected to .9.2 renderings.

MikieMikie
Feb 20, 2008, 11:22 AM
Hrm. I just started re-encoding with 0.9.2 and haven't started tagging files yet. I hope this isn't a bug. How about renaming the files with an mp4 extension? Does that work?

I had no problem tagging with MetaX. I re-encoded Natural Born Killers. (I aways rame them .m4v)

dynaflash
Feb 20, 2008, 11:39 AM
Realize that before take 2, the apple tv would not accept any > 4gb movies. This is new for take2 and I would imagine due to the new HD rentals.

Without the m4v file extension, the take 2 will not recognize the new aac + ac3 dd sound tracks. So I suggest going with that for all of your atv encodes.

rWally
Feb 20, 2008, 11:41 AM
One was 1.91Gb. Another 2.47Gb. A third was just 106.9Mb.

Also, while the suffix .mp4 or .m4v will go into iTunes just fine, it appears only the .m4v suffixed files will show up in :apple:TV Take 2. After I tagged all 3, the one that was 1.91Gb was suffixed as .mp4. All 3 went into iTunes just fine, and everything looked normal.

However, only the 2 ending with .m4v were showing in my :apple:TV movies list. I switched to "trailers", then back to "My Movies", etc, but none of that made the .mp4 suffixed file show. Then, I went back over to the Mac, changed the suffix to .m4v, deleted the file out of iTunes, and dropped the newly renamed file in. Everything looked normal again in iTunes. When I checked the :apple:TV list, the missing movie now shows.

I have many movies rendered by previous versions of Handbrake that suffix with .mp4. They all show, so this looks like something newly connected to .9.2 renderings.

That's strange. All my .mp4 files are still showing up on my :apple:TV take 2.

HobeSoundDarryl
Feb 20, 2008, 12:08 PM
rWally to clarify, my files ending with .mp4 (but encoded prior to Handbrake .9.2 also show up in :apple:TV take 2 My Movies folder). However, a new encoding in .9.2 adding in the AAC+AC3 track wouldn't show up until I changed the suffix to .m4v (it would go into iTunes just fine, but wouldn't show in the "My Movies" list).

As Dynaflash is advising, apparently all of the AAC+AC3 renders should be suffixed .m4v to show properly in both places.

dynaflash
Feb 20, 2008, 12:16 PM
As Dynaflash is advising, apparently all of the AAC+AC3 renders should be suffixed .m4v to show properly in both places.

Note: The built in appleTV preset automatically does this for you. There is also a spot in HB's preferences where you can tell it to to it automatically add the .m4v extension to the file name of all mp4 encodes instead of the default .mp4.

Hope that helps.

rWally
Feb 20, 2008, 12:19 PM
rWally to clarify, my files ending with .mp4 (but encoded prior to Handbrake .9.2 also show up in :apple:TV take 2 My Movies folder). However, a new encoding in .9.2 adding in the AAC+AC3 track wouldn't show up until I changed the suffix to .m4v (it would go into iTunes just fine, but wouldn't show in the "My Movies" list).

As Dynaflash is advising, apparently all of the AAC+AC3 renders should be suffixed .m4v to show properly in both places.

Oh, alright. I guess I misread your post. I've been keeping mine as .mp4 so my ps3 will recognize and play them as well. Obviously, if I go the 5.1 route with the :apple:TV preset it won't play the file anyway so I might as well keep it as .m4v.

I don't suppose there is a way to get a file that plays 5.1 on an :apple:TV and a ps3 is there?