PDA

View Full Version : Help! My iBook g3 won't charge or startup.




Caelum
Mar 8, 2008, 07:25 AM
Hi all,

I have an iBook g3 running Tiger that I bought second hand almost two years ago that has been working perfectly up until yesterday.

I use it for uni during the day and usually turn the machine off overnight while it charges. The other night I left it 'asleep' while charging instead of off. When I came to use it in the morning it would not wake up and was totally silent although it's pulsing 'on' light in the front part of the casing was on. The charging cable was still connected and was green, indicating a full charge, but the battery-life light display, when pressed, showed only a single light, which flashds a few times, indicating the battery wasn't fully charged.

While trying to get the thing to do something I removed the battery. This caused the ibook to turn off the pulsating light - it was completely off and apparently not drawing power from it's adapter, which was still plugged in.

I have been trying since then to get the computer to turn on. No matter how long it is left charging, the battery never indicates anything other than a single light with a few flashes, the computer will not turn on and the cable of the charger stays green when plugged in.

I have tried inserting an older battery - which I know worked, it just only used to hold an hour's charge or so - and it will not charge at all.

I have also tried resetting the PMU, which appears to have done nothing

Does anybody know of anything else I could try?

Thanks for any help.



kajitox
Mar 8, 2008, 02:20 PM
I've heard of this problem before, and it's almost always due to water damage on or around the MagSafe...is this the case?

mperkins37
Mar 8, 2008, 03:17 PM
IBook G3's Didn't use MagSafe, it came out recently.

Chrismcfall
Mar 8, 2008, 03:24 PM
It kinda sounds like a Logic board problem.

Caelum
Mar 8, 2008, 05:17 PM
It kinda sounds like a Logic board problem.

Excuse my lack of knowledge here... is this something I can fix?

Quint
Mar 8, 2008, 06:12 PM
This is a common problem on the G3 Powerbook - not sure if the iBook is the same. On the powerbook, it happens when the permanent battery (sometimes referred to as the pram battery) dies. To fix it on the powerbook, you can open the keyboard using the tabs between the F keys and carefully unplug the battery connector from the logic board. Then it powers up without a problem. I am not sure if you can duplicate these steps on the ibook.

Caelum
Mar 8, 2008, 06:13 PM
Hi again, thanks for your help all

Chrismcfall - thanks, it does appear to be a logic board problem. A friend allowed me to remove his logic board from his identical machine and try it in mine - everything worked, though it was a fiddly process. I guess I will need to fork out for a new one.

Thank you.

Chrismcfall
Mar 8, 2008, 06:26 PM
A new logic board cost me 40...and they're not too hard to fit.

Chrismcfall
Mar 9, 2008, 04:02 PM
Hang on....Logic board?
Duh, I mean DC Board.

Warbrain
Mar 9, 2008, 04:10 PM
Hang on....Logic board?
Duh, I mean DC Board.

DC Boards on the iBooks have to be the simplest thing to replace that's internal. Everything else requires a near-total disassembly.