PDA

View Full Version : Mac Mini overactive fan?




RealaT
Mar 16, 2008, 07:11 AM
I know someone else has just posted an almost identical problem to this, but I decided to start a new thread because I would like to get into detail about my situation.

I recently bought a used Mini from eBay with these specs:
Intel Core Duo 1.66
80gb HDD
2.4x Superdrive
2GB Ram (Kingston brand upon inspection, so it has been user modified at some point)

While using the machine I noticed that the fan speed would rapidly increase while doing non-intensive tasks. The most common causes of this seems to be HDD access and scrolling the screen. The fan speed is not permanent and does slow down once said activity has stopped and the machine is idle again.

It is very easy to trigger this action, the best way i've found is that if i open iTunes and then scroll up and down constantly using the mouse wheel the fan speed will go from 2000 to over 5000 in a matter of about 30 seconds. Again, once i stop it will slow down again.

I don't think temperature is an issue as smcfancontrol reports the CPU temp at 35-40C. I have since swapped the HDD for a 120gb and that hasn't changed the problem so i don't think it is HDD related. I have checked the fan control cable and it is securely plugged in. Looking inside i can't see any other signs of wear or damage.

The thing that bothers me most though (i can live with the sound because i used to use a home-built pc that sounded like a jet engine 24-7!!) is that i've now noticed that when the fan is at it's peak, the bluetooth will start to become unresponsive which is very irritating as i use an apple wireless mighty mouse and alu keyboard.

I tried a full re-install of leopard which hasn't fixed the problem. I've also tried resetting the SMR (although i'm not sure i'm using the correct procedure) and resetting the PRAM and neither has made a difference.

Out of desperation I tried installing Windows XP via Bootcamp to see if it showed the same behaviour. In windows the problem is even worse with the fan running loud constantly and both mouse and keyboard being very unresponsive even when the machine is idle.

So I would like to see if any of the experts here have any suggestions. I have no objection to taking the casing off again to check any components. I would take this to an apple store, but the nearest one is over 200 miles away.

Any help is very much appreciated.



RobertD63
Mar 16, 2008, 12:11 PM
That is defiantly not normal. I would open it up and look for any cords that are not plugged in. You have to unplug the fan cord to get to the ram. EDIT: Sorry i didn't catch the part were you said you checked all the chords. Does it still have applecare? Like as in did it have 3 years of it when you got it in the auction? Also i would Quit and get rid of SMC fan control to see if that helps at all. Or maybe play with the setting in it. I think SMC is causing all of the trouble. Good Luck
-Robert :apple:

RealaT
Mar 16, 2008, 01:56 PM
Thanks for the suggestions.

The problem isn't anything to do with smcfancontrol as i haven't installed it at all in my latest install of Leopard.

How can I check if it has Applecare on it? There was no mention of it on the auction but I seem to remember you can enter the serial on apple's website and it will tell you the warranty status.

A little more information: I can get the fans to trigger using TechTool Pro and running the RAM tests, after about 25-30 seconds of testing the fan will be running at full speed. So it would appear to be RAM operations that are causing this? I've tried replacing the Kingston ram with 2 sticks of Samsung that were in my Macbook Pro and it hasn't changed the behaviour.

VoodooDaddy
Mar 16, 2008, 03:30 PM
Enter the serial here to check Applecare status:

https://selfsolve.apple.com/GetWarranty.do

mars526
Mar 16, 2008, 09:50 PM
The problem with my Mac mini still presents. If you open Frontrow the fan speed goes straight to 5000rpm.

Since I only bought it from apple online store for just a week, apple offered to return the item with no extra charges, so I accepted. Thinking of buying a new macbook pro now.

4JNA
Mar 16, 2008, 11:18 PM
so the 'check serial number' is the link above or the support tab at apple.com.

it's not smcfancontrol. i run the current version on all of my intel systems, and it works great. mini/imac/mac pro. my systems would overheat without smcfancontrol actually, as i FOLD (http://folding.stanford.edu) and need to increase the stock fan speed.

first thing i would try with the intel is resetting the SMC (http://docs.info.apple.com/article.html?artnum=303446), that is the 'system management controller'. does power, FANS, etc. in a nutshell, unplug every (EVERY) cable from the mini for 15 seconds or more, and then reconnect and restart.

second is that it sounds to me like an out of whack temp monitor. there is a temp monitor connected to the bottom of the cpu heatsink, and if it has come loose or is not making good contact, it could cause this problem. see the attached pic;
http://i108.photobucket.com/albums/n15/4JNA/P1010005.jpg


you could open 'activity monitor' (applications>utilities) and watch, but my guess is that every time the cpu ramps up, the fan goes nuts. if the SMC reset doesn't fix it, then you might look at the sensor since you said no problem to the cover off.

if you are out of applecare coverage, it could also be as easy as a disassemble, clean/replace the heatsink compound on the cpu (recommend Artic Silver (http://www.arcticsilver.com/)), and clean out fans and internals on the way out.

also of note, i had one mini purchased from ebay running hot, a quick trip to the air compressor fixed it right up, and now is running 100% on both cores at 61 degrees C. not much room in there, and any dust/debris can really cause problems. blow from the back, then around the bottom edge, and then the back again. or just take the cover off and have at it.

best of luck with the repair!

RealaT
Mar 18, 2008, 03:25 PM
An update for anybody interested...

I was mucking about with the ram last night and I discovered something. When there is only 1 stick of ram installed, the mini runs quieter... not as quiet as it should but it's 10 times better than it is with 2 sticks installed.

It doesn't matter which ram stick I use (Kingston or Samsung) or even which socket it is connected to. As long as there is only 1 stick installed the mini runs a lot quieter than with 2 sticks.

Frankly this is a happy result for me as i don't really need 2gb. I have a macbook pro for all my power use needs. But it's still an odd behaviour.

Any thoughts?