PDA

View Full Version : Shark is broken?




Thomas Harte
Mar 27, 2008, 06:37 PM
Based on my experience, Shark seems to be broken more often than not. Having tried to use it today, I find that it displays a message saying "No sampling configurations available." Once it starts, there is no way to attach it to a process and trying to create a new sampling configuration fails because the related dialogue doesn't actually have an option to create a new sampling configuration — just to duplicate old ones, none of which exist.

I have tried trashing its preferences file and running it as another user just to be sure. Neither of these ideas solves my problem.

I'm on OS X v10.5.2. Shark is version 4.5.0 (156.8). Xcode reports itself simply as version 3.0. All of my developer tools came from the OS X v10.5.0 install DVD, and as far as I am aware they are the latest (stable) versions.

Is there a fix for my problem?

EDIT: screenshots:
http://b.imagehost.org/0341/Picture_3.png
http://b.imagehost.org/0341/Picture_1.png
http://b.imagehost.org/0341/Picture_2.png



ebel3003
Mar 27, 2008, 06:55 PM
Shark 4.6.0 (189) works fine on 10.5.2. Perhaps you should install the updated developer tools included with the iPhone SDK beta.