PDA

View Full Version : printing wireless, with dlink


zedder
Nov 9, 2003, 11:48 AM
hi there,

im currently trying to get a small network set up, and having trouble with the printing side of it. I have a dlink router with built in parallel print server. Im trying to connect with an ibook (osX).

I am able to communicate with router, i can get onine etc no problem. But i cant seem to get the printer to work through wireless. It does work wired.

I have tried many setting etc,,with no luck

It seems as though i have read everything possible, and after searching these forums, i could find anything already there.

anyhelp here would be much appreciated.

thanks

stcanard
Nov 9, 2003, 11:45 PM
Mine seems to work no problem. If yours works wired but not wireless, that sounds like an oddity in the change in the network. Things you might want to look into are:

Are you using DHCP? Does the router give a different address range for wired vs. wireless clients? If so, try setting up a static address temporarily and see if that helps.

Are you using different network profiles (locations) for the two settings? Maybe something is accidentally disabled.

Are you certain you are connecting to _your_ router wirelessly? I live in a condo, and had a hell of time trying to figure out why my WEP key wasn't protecting my network (within certain definitions of protection...) until I realized the computer I was testing with was just bypassing my network and connecting to somebody else's.

There is really no reason why wired should work, but wireless shouldn't.

I'm using a D-Link 714P+ which has a parallel port connection for the printer.

The settings I used were:

IP Printing
Printer type: LPD/LPR
Printer Address: <ip of my router>
Queue Name: lp
Printer Model: <driver for my printer>

This is on Panther, with an HP printer.

zedder
Nov 12, 2003, 01:57 PM
i had made a bit of an error, it worked through the usb not ethernet..oops.

anyhow either way im not able to print through ethernet , or wireless. Ive d/l the latest driver from NEC for OSX, and ive tried following the setup for ip printing. Ive d/l gimp print and it did have some drivers for NEC but not the model 1400 that i have.

It seems that from all the research ive done this is possible as long as i have the correct driver...but i dont know if what i have is good enough?

any other support would be great

thanks!

stcanard
Nov 12, 2003, 03:46 PM
Can you verify on another computer that the printer works from the parallel port, through the cable you are using? It may be something to do with the parellel port on the printer, or the cable connecting that and the dlink.

If you can print through USB that means you have all the drivers you need. All IP printing does is open a socket and send the raw data to that socket.

Do you get anything at all when you try to print across the network -- does the printer respond (wake up or something) or is it just dead?

Try http://linuxprinting.org they have a huge collection of informatinon and an OSX specific section. Maybe something there can point you in the right direction.

zedder
Nov 12, 2003, 07:21 PM
oh my gosh,,,it appears that im going to need to be a genious to set up a ppd or what ever all that is at the linux site...WOW!

Ive read through a bunch of pages and thats quite difficult!

In all honesty i didnt expect setting up a printer to be this much. Ive been reading and trying different setups now for over a couple weeks...seems kinda crazy to just get a printer to print??

I really dont understand what im supposed to do with all that cups, ghost print, ppd , etc.... guess if there simply isnt a driver or file patch i may be in for quite an experience.

i still would appreciate any more direction you have to offer

thanks!

stcanard
Nov 12, 2003, 09:06 PM
It shouldn't be that hard, OSX has most of it hidden under a GUI :) Linux people just like to do it the hard way. CUPS is the general printing interface that Print Centre abstracts.

In my case for my HP printer it was as simple as downloading a package on the site and running the installer. Go into the OSX section, find the printer you use and there should be fairly simple instructions.

It only becomes a problem if your printer isn't officially supported, then you have to get into the guts of it. If you have it working through USB on OSX then you've already got what you need.

If you do have it working USB (that's the impression I get from your previous messages?) I'd really guess that the problem is between the router and the