PDA

View Full Version : Recover data over firewire: disk wont appear




mediumofmeaning
Apr 26, 2008, 09:40 PM
Hello,

I have a recent macbook which has a corrupted hard drive of some sort; leopard wont boot, when booting from a disc, permission repair fails. a windows partition does show up, but that wont boot. i have a feeling everything will have to be wiped to get any functionality but...

I want to move data over to my imac and attempt to save what I can, however after connecting the two via firewire and booting the failed computer in target mode, nothing shows up on the host computer.

are there any other options, or ideas that someone might have? i appreciate it, thanks.



xUKHCx
Apr 27, 2008, 06:09 AM
I don't really have any experience with Target Disk mode. Unplug and other devices from the two machines so that it is literally just them connected (plus keyboard and mouse obviously). Try restarting it again as it might kick it into action.

Is the disk listed in Terminal?

Open Terminal from your utilities folder and type "diskutil list" without the quotes and press return. This will bring up a list of the drives connected to your computer. For example the read out from my computer


/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *232.9 Gi disk0
1: EFI 200.0 Mi disk0s1
2: Apple_HFS Siegfreid 225.0 Gi disk0s2
3: Microsoft Basic Data .Local Disk 7.6 Gi disk0s3
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *7.5 Gi disk1
1: EFI 200.0 Mi disk1s1
2: Apple_HFS Humphrey the Great 7.2 Gi disk1s2


As you can see from the above I have two drives (/dev/disk0 and /dev/disk1) attached to my computer.

merl1n
Apr 27, 2008, 09:15 AM
Hello,

I have a recent macbook which has a corrupted hard drive of some sort; leopard wont boot, when booting from a disc, permission repair fails. a windows partition does show up, but that wont boot. i have a feeling everything will have to be wiped to get any functionality but...

I want to move data over to my imac and attempt to save what I can, however after connecting the two via firewire and booting the failed computer in target mode, nothing shows up on the host computer.

are there any other options, or ideas that someone might have? i appreciate it, thanks.

Try booting in Single User Mode (cmd-s at powerup) and running a filesystem check and repair:

At the single user prompt, type the following:
/sbin/fsck -fy then hit the return key

Keep repeating this until you see no more error messages. If after 5 repeats of this you still see errors, you definitely have a serious problem with the disk.

The type:
reboot (followed by the return key)

I am also going to send you a private message.