PDA

View Full Version : G4 iBook "Cry for Help" Thread




NIPRING
May 3, 2008, 12:50 PM
Ok, i bought a 12" G4 1.2ghz iBook that apparently had a glass of wine spilled on it. I opened it up and proceeded to clean everything as I went. But it really didnt look like there was much fluid that got inside it.
Video output is working fine.
Anyway, the backlight is not working on the screen. So far, i've replaced the inverter board, tested the lcd in another ibook (to see if the CCFL was burned out, which it wasnt), inspected the inverter cable end to end looking for breaks in a wire, its fine. Gave a good press to the left of the trackpad in hopes of possibly reseating the video, no luck there. I even check the micro fuse on the bottom of the logic board (visual inspection only as i have not bought a new multimeter yet).
I'm not sure if this is related to this issue, but there are somethings i cant get to work, like booting into open firmware (in order to reset the NVRAM) or reset the PRAM, and when i try to reset the PMU by:
"Reset the power manager by simultaneously pressing and then releasing Shift-Control-Option-Power on the keyboard. Do not press the fn (Function) key while using this combination of keystrokes"
"Wait 5 seconds."
"Press the Power button to restart the iBook computer."
The ibook is off when i push Shift Control Option and Power, but as soon as the power button is pushed it in this button combination the ibook turns on. So how do i wait 5 seconds and press power to restart if its already on?

Thanks for any and all help.

Bill



misterredman
May 3, 2008, 03:24 PM
Since you talked about spilled fluid, are you sure the keyboard is working properly? Maybe one of the needed keys dowsn't work.

fall3n
May 3, 2008, 03:52 PM
Replace the inverter cable. If it still doesn't work it could be the actual connector on the logic board seeing as this was a liquid spill. Any signs of corrosion on the logic board? As for the PRAM, are you sure your doing the correct procedure for your iBook specifically? See http://docs.info.apple.com/article.html?artnum=14449#faq If you are, then as the poster above said it could be your keyboard - if all those keys work fine, then it could be the logic board.