PDA

View Full Version : Interesting Mac mini HDD failure




miniConvert
May 5, 2008, 04:13 PM
Last night my Mac mini ran into difficulties. It was fine one moment, and then it'd go into a 10-20 second pause before anything else would happen. At that stage it looked like a software issue, so I (eventually) told the thing to restart and it did.

On restarting, it sat at the grey Apple logo and pinwheel indefinitely. No HDD activity... just nothing. So, I used the OS X disc to get into Disk Utility and verified the drive. The error was 'Invalid node structure'.

Unfortunately Disk utility, or fsck in single user mode, was unable to fix the error. However, I got the mini into Target disk mode and, with somewhat sporadic transfer speeds, copied off all my music and pictures. It was all backed up anyway, but I didn't want to risk there being any issues restoring from Apple's Backup.app, especially when I had the chance to grab my data in raw form.

Then came todays Applecare conversations. It took 3 calls in total. During the first, they made me do an erase and install, insisting that this would fix the problem. In the second, they said that actually I needed to first erase the entire disk, then do an erase and install, and that would definitely sort it out. I went along with these two steps despite feeling pretty certain from the start that the drive was defective. I called up the third time when the 'Erase free space' had obviously hung and the helpful agent arranged for collection of my mini. Still, it took 3 calls and a total of about an hour on the blower on an 0870 number.

It worried me a little that Apple were so sure that this total loss of data was entirely OS X's fault (and the underlying file system's) rather than the hardware :rolleyes: Tiger is better than that!

So, there you have it, a very curious HDD failure I feel. It's a 120GB Seagate drive, the highest capacity available when I bought the thing (CD 1.66). I had an Apple-supplied Hitachi drive (though not the boot drive) go on me in a similar fashion in my Mac Pro. Both drives still had Verified SMART status. Is this just how modern HDD's die? Or have I just been very lucky to experience two of these 'slow deaths'? :D

Just thought I'd share! I'm on the MBA at the moment... and ever grateful of it's SSD.